PDA

View Full Version : From leaves on paper to leaves without paper.



robobob
12-04-2015, 01:29 AM
Hi, I imported an tree object from DAZ studio. The maps were included, but when I load the object into LW (vs. 9.6) the leaves show the white backing in the maps. 131321. The object should look like the next image:131322. The next images are someof the maps included with the object: 131323, 131325, 131326. What should I do to get the proper image from the maps? Thanks for your help. Rob

ernpchan
12-04-2015, 02:02 AM
It looks like you're missing the alpha channel. In the Image Editor, does it show that these images contain an alpha channel? If the do, you want to clone the entry in the Image Editor and set the entry to be alpha channel only and then apply that image entry to the transparency or clip map.

magiclight
12-04-2015, 10:41 AM
Also notice that transparency maps from DAZ are inverted, black should be white and white should be black in Lighwave, you will see that the "invert layer" options is set or you need to set it or you can set the image inverted in the image editor under the "Editing" tab.

In case of leaves and things that are either black or white in the transparency map (no shades of grey) it is better to use "Clip map" instead of "Transparency", it's faster and don't cause any specular artifacts (with transparancy the surface is still there even if it's 100% transparent, with a clip map the surface is not there).

And finally, if you use transparency you may need to crank up the "Ray recusion limit" in the render Globals/Render tab otherwise you will get white pixels between in the leaves (12-15 usually works fine).

It should work fine, here is an import from an OBJ exported from DAZ without anything done to it (I did set the speculaity to zero though, see below):
131330

I actually think the problem is that you have a specularity value set for the leaves (it's often wrong after an import), you cannot have specularity set for a surface that is transparent, it will be like this, you need to set specularity to zero or use a specularity map that has zero vales in the transparent areas.

Just select all surfaces and set "Specularity" to zero and see if it looks better.

robobob
12-10-2015, 12:46 AM
Thanks for your reply. I'll check it out.

- - - Updated - - -

Thanks for your answer. It looks good. I'll give it a shot and get back to you.

Sensei
12-10-2015, 01:57 AM
What should I do to get the proper image from the maps?

What you attached are jpg,
they don't have alpha channel,
it must be therefor separate file..

Try generating such in Photoshop using these images as background..

JonW
12-11-2015, 01:06 AM
Using png is good as you can have you files in greyscale and when open within LW the file are 1/3 the size. Channels basically only need greyscale images.

magiclight
12-11-2015, 04:58 AM
DAZ Studio do not use alpha channels, all transparency maps are in separate B/W jpg's (the once that are in the post are the texture maps, not the transparency maps).

And the white parts in the render are half transparent so I am pretty sure the problem is the specularity and not the transparency.

robobob
12-14-2015, 12:40 AM
After opening the "Surface editor" in LW, qhen I select "edit image" for a given map item, it looks like the alpha channel is not enabled, but I cannot enable it. If I select the "advanced" tab in the top menu of the surface editor, the alpha channel box reads "surface opacity." What does that tell you? What do I need to do? Thanks for your help.

Sensei
12-14-2015, 12:58 AM
Like I said JPEG/JPG format does not have any alpha channel..

magiclight
12-14-2015, 07:18 AM
Before you mess around with the transparency, have you tried what I said before:
"Just select all surfaces and set "Specularity" to zero and see if it looks better. "

robobob
12-29-2015, 08:06 PM
Thank you! I did set Specularity to zero and it worked. Much appreciation.