View Full Version : Hitfilm 4 Pro

11-21-2015, 11:25 PM

The alembic support looks interesting. Boris FX included. Everything else looks so so.

wibly wobly
11-23-2015, 05:17 AM
Alembic is a nice addition but, as far as I know it doesn't import camera data which is a huge "why not?" to me. I picked up the update specifically because I assumed it would have. Hopefully, it's a feature request that other people are asking for and it will be in it as a free update. Otherwise, I think the only way to get camera data in is with a .ma scene file, which is somewhat not everyone has access to. Aside from that, it seems like a continual refinement. Nothing really earth shattering so far from what I've seen.

01-19-2016, 07:50 PM
If your after a Lightwave to Hitfilm exporter here is one created for version 3:

It should work with version 4 but haven't tested it yet. It exports lights, nulls and camera.

wibly wobly
01-25-2016, 10:02 AM
Thanks. I am aware of that script. It seems to work just fine the few times I've tried it, except it doesn't seem to work with parented objects. I haven't tried it yet but, I would think the only way around it would be to bake the keys of a null / camera and unparent it before exporting. It's another step from a feature I'm surprised they didn't just have from the start (in Hitfilm's Alembic support that is).

01-25-2016, 03:21 PM
I just checked the parenting and it does work. However I think I know what might be going wrong. The 3d camera the is exported with the nulls is just a placeholder and not the correct scene camera you will need to export the camera using the LW2HitFilm_camera script. This is my fault for not making this clearer as I haven't gotten around to combining all the code yet.

In HitFilm import the composite shots and copy the camera from its comp shot into the null comp shot. Hope that helps. :)

wibly wobly
01-25-2016, 03:45 PM
I can't recall if I saw a camera export script but, if I just missed it then that's great. It worked besides that one issue I had. Perhaps I may have been using an older version as well. I'll have to double check. Somewhat spoiled with the AE link button here.

Shawn Farrell
02-20-2016, 12:23 PM