PDA

View Full Version : Kinect 2 fun



Zerowaitstate
11-20-2015, 07:50 PM
any one else getting the program can't start because kinect10.dll is missing issues.

to be clear i do have xbox one kinict / MS kinict 2, i also have a coupple of kinict 1 for windows devices but they have not been near this OS at this point

ive installed the MS SDK .

every time i launch LW 2015 im getting the program can't start because kinect10.dll is missing from you computer.....

kinect shows in device manager as working

win 8.1 x64

have tried in win 10 yet

any help appreciated, cheers

magiclight
11-21-2015, 04:26 AM
Have you searched for kinect10.dll on your computer ? do you have it on your hard disk anywhere ?

It may be in a directory where LW don't see it.

DogBoy
11-21-2015, 05:53 AM
on the thread about the freebies (http://forums.newtek.com/showthread.php?148875-WOW!-Thanksgiving-Gifts-from-NewTek!&p=1456027&viewfull=1#post1456027)

i am getting a kinect20.dll missing on layout startup, i followed the initial install directions and also installed the the kinect runtime from my account. What's that about ?


I was getting the same message. I went to Microsoft website and downloaded the KinectRuntime-v2.0_1409 and that fixed it.

So, maybe give that a go?

Zerowaitstate
11-21-2015, 09:44 PM
mmm. I had the skd 2 installed already, and have since retested several of the built in wpf demos, they work fine, so the device is ok. i also ran the 2.0 run time still the same error.

i did system wide search for kiect 10.dll and did not find it, doing some more web research i will post if i come up with a solution.

If this fail i migh jump in to windows 10 see if any better results there, i am not sure how the nervon key will behave it is the same hard ware just different OS. LW 2015 seems happy so hopefuly it the same deal.

tcoursey
11-25-2015, 06:43 AM
let us know how things work out. I was thinking about getting Nevron installed again and trying my XB1 kinect. Wasn't much happy with results from original Nevron and Kinect 1....for me.

Greenlaw
11-26-2015, 10:01 AM
I spent a few minutes on this last night. I already had the Kinect 2 SDK installed because I use these sensors for another program. After properly installing NevronMotion 1.1, the Kinect One (v2) shows up and it appears to be sending data to Lightwave.

The documentation states several ways to install the software and I did have trouble with the first method, copying NevronMotion to the Plugins folder down inside User folder. Lightwave automatically loaded the plugins but the KinectOne was not showing up.

However, when I installed it like a regular plugin from my own Plugins folder (for third party tools) in the main Lightwave directory, it showed up immediately.

The docs do state that the KinectOne options are not available yet in NevronMotion. I thought that was odd. This makes me think KinectOne support may be functional but it is also still being worked on.

I loaded the KinectOne Genoma rig and it collapsed on the ground. But that was almost expected as I was only messing around at this stage, and I didn't actually have the KinectOne set up for human motion capture yet.

That's as far as I got. Will look into this further today if I can manage the time.

Regarding the 'Read Me' docs: I don't know if it's just me but the bare bones information is super confusing. While I found the software was actually pretty easy to install, I think the docs made the steps a lot more difficult to follow than necessary.

G.

P.S., the docs also state that you should not copy NevronMotion 1.1 over previous releases, so make sure the old version is completely uninstalled.

Greenlaw
11-26-2015, 10:42 AM
Sorry for the cross-posting but I got it to work.

131208

Here's my daughter waving. I captured this using my tablet computer running Windows 10.

It's actually pretty to easy to activate but, as mentioned above, the docs make it more confusing than necessary. I'll post a quick walkthrough with a demo clip after Thanksgiving dinner today. 'Dinner' is going to be early so maybe this afternoon.

Anyway, yes it works and it definitely works better than v1.

G.

Zerowaitstate
11-26-2015, 05:06 PM
right so i assume your not getting any dll issues, it looks like i have got stuck with confusing install procedures. I just assumed they were correct to i would not get an error being raised, would be nice in LW would step in with some clarification, it may well be that i am also getting data i just hadn't pushed forward as i was thinking the error was blocking any further action i will look into it over the weekend

Greenlaw
11-26-2015, 07:59 PM
Here's a Kinect One/NevronMotion setup tutorial I whipped up this afternoon:

Setting up Kinect One for NevronMotion in LightWave 2015 (http://forums.newtek.com/showthread.php?148971-Setting-up-Kinect-One-for-NevronMotion-in-LightWave-2015&p=1457058#post1457058)

I hope it's helpful.

G.

Zerowaitstate
11-27-2015, 07:26 PM
Cross post...

Success ! ! !

Things that caught me up ....

- did not install driver from the LW site /Face Palm
- did not initially have HID ticked in Virtual studio > Device manager
- did not have KinectOne_Skeleton_SKL0.lws loaded ( i had earlier version which no doubt works with V1 sensor)

this is so much fun i am planning to project on to the side of my house and have a two story Santa waving at cars and kids real time as they drive bye, should be a blast.

link from above got me going

http://forums.newtek.com/showthread.php?148971-Setting-up-Kinect-One-for-NevronMotion-in-LightWave-2015&p=1457058#post1457058