PDA

View Full Version : Opening LWO on Mac OSX



riki
12-08-2003, 09:49 PM
I have an annoyng problem on OSX. Often when I double click on a LWO it launches another APP. For ages it was launching Divx, until I trashed that off my system. Now it launches the Uninstaller for Maya. What's up with that??

It sounds like a good cue for a joke, but I'm not really in the mood for humour.

Also when I use 'Get Info', the list of recommended APPs does not include Modeler. Modeler is ghosted over.

Okay so I set it to 'Modeler' and select 'Change All' . It seems to work properly a few times and then reverts back to Maya.

I've also fixed disc permissions but that doesn't seem to have any effect.

I'm using OS10.1.5 if that makes any difference??

ingo
12-09-2003, 01:58 AM
That happend to me too long ago, thats why i always start modeller or layout first. Lightwave is not a Mac app, so thats why i'm always careful with things that are usual for us Mac users but not for Windows users.

designvs
12-09-2003, 07:33 AM
Just right click and choose "Open With". Then just check the box that says "Always Open With" and then just select Modeler as the application. This should solve the problem.

riki
12-09-2003, 08:25 AM
designvs no offence but you should read my post before replying to it.

Chazz
12-09-2003, 08:30 AM
Change 'enable recommended applications' to 'all applications' and select the version of Modeler you want.

ingo
12-09-2003, 12:41 PM
Just a thought, have you updated prebinding ? I'm not sure if this helps anything, but you never know.

eblu
12-09-2003, 12:57 PM
well we all know LW doesn't follow standard UI conventions. This exact issue is one of my many pet peeves with LW. They traditionally ignore Apple UI standards leaving users with an experience that is messy to say the least. Riki, you are completely right to get frustrated. There is a bit of work that LW must do in order to properly support ITS OWN FILE TYPE, and as far as I know, it doesn't do it. No matter how many times you Fix the Open with App menu, it can easily come undone. And Unfortunately there is no easy workaround or User-level fix to this.

in cocoa (xcode) its as easy as typing lwo into the correct box. In carbon, I expect its a bit more difficult.

Kuzey
12-09-2003, 02:16 PM
Have you tried "save as" to overwrite the file ??

You just never know with these things.

Kuzey

riki
12-09-2003, 03:34 PM
I really can't understand why they don't fix things like this. I know it's not a show-stopper problem, and that there's are work-arounds. But doesn't it really boil down to taking some pride in your work.

None of my LWO or LWS have ever had Icons since I migrated to OSX, they all just look text documents.

Kuzey
12-09-2003, 04:05 PM
None of my LWO or LWS have ever had Icons since I migrated to OSX, they all just look text documents.

That means the Mac Creator and Mac Type settings have been changed to "????" & "????".
Which usually happens when you bring lw files from the pc to the mac.

Here's what they should be:

Lw Object code
Mac Creator: "LWMD"
Mac Type: "LWOB"

Lw Scene code
Mac Creator: "LW3D"
Mac Type: "LWSC"

Without those codes....LW &/or the OS won't know which application they belong to...even if you include the .lwo & .lws extensions at the end!!


I think you can use Applescript to fix them...if you know what you're doing.

ps..if you boot up in Mac OS 9 doe's the problem still exist??


Kuzey

Kuzey
12-09-2003, 04:24 PM
Here's an example.

I fixed the Mac Type/Mac Creator codes for Guffy....while leaving the gun untouched.

Kuzey

noiseboy
12-09-2003, 04:33 PM
Riki, I have every sympathy with you for feeling frustrated by these issues, I have a script which exports a STL file, on one of my Macs it will only write to my user desktop on the other two it will write to anywhere, same script OS etc..

I'm not sure what I'm doing right but all my object and scene files have the correct icons, albeit lo res pixelated ones, and they launch Modeller and LW from the files. I am running OS 10.3 (Dont Ask!), but I can't imagine that it should be any different in 10.1.5, you've already tried the thing I was going to suggest, You could try the file typer utilities here but I think its a OS9 app;
http://www.exch.demon.co.uk/file.htm

riki
12-09-2003, 04:45 PM
Thanks for the replies. It looks like I need to find a file typer for OSX. I use to have APP in OS 9 that would let me create my own Droplets which was great becuase you could batch process a number of files. But they didn't work on OSX.

I'll check next time when I boot in OS9 if they keep the file icons.

noiseboy
12-09-2003, 05:08 PM
Riki
you might want to try this
http://www.everydaysoftware.net/quickchange/index.html

along with the info that Kuzey posted you should be able to make your files double clickable. Good luck

pdrake
12-09-2003, 05:23 PM
i know they made an app called filetyper for os9. i've had to use it on many occasions. check this out. maybe they've updated it. i'm really busy so i didn't research it more. (not too busy to read and post in the boards)

filetyper home (http://dazuma.freeshell.org/filetyper/)

riki
12-09-2003, 05:59 PM
Quickchange looks promising, thanks for the link.

Also I checked File Typer but from the screenshots looks like it's just for OS9

eblu
12-11-2003, 02:29 PM
thats all fine and good, but it doesn't Fix the original problem.

the current incarnation of mac os X uses dot extensions, NOT file/creator codes. It still supports file/creator codes, but they are slowly going away.

Lightwave, Used to support file/creator codes, but since the port to osX, its obviously been broken, and does not support them as well as it used to.

Here we are in the laughable position of having a Version of Lightwave that Doesn't support its own dot extensions. Something that works flawlessly on every other platform.

Why exactly is that? Apple marketing might say that it only takes a few hours to port from mac os 9 to os x, but Thats marketing drivel. Its got no connection to the real world. In the real world things break, and you cannot just ignore them. Otherwise they slowly spread and grow like potholes. When they ported LW to os X it was assumed that there would be no problems. Even if there was testing, there was no research into easier/better ways of working with os x.

riki, this problem doesn't affect everyone, but that is not proof that the problem doesn't exist. Apple used to use a term "robust" to describe the attitude of programming for every eventuality, so that the user can't be faced with problems like this. It meant spending a great deal of time on design, and testing. Its sad that Nobody (not even apple these days) can spend the kind of time (or money) it would take to do that, but I seriously believe that the Mac specific code of LW stands out as one of the worst examples of this mindset of shipping something that is not done right.

I don't like saying that, I re-wrote it quite a few times to make it sound less severe. But it still comes back to the bare fact that I personally don't believe Anyone at Newtek really understands MAC OS X from a development standpoint, otherwise it would show in the product, and the choices they make.
and the no-brainers like dot extensions, would not be so difficult.

riki
12-11-2003, 04:13 PM
I have to agree with you there. I've heard there's a lengthy process they have to go through when fixing bugs. But it does strike me as being odd when a problem like this exists.

I only wish that they could more frequent patch updates, to fix small bugs like this that would save us all a lot of pain.