PDA

View Full Version : Why do characters have square holes?



hdace
11-10-2015, 12:42 PM
A few characters in our project have a medium high "face" poly resolution. Other characters with subpatching don't have this, and it only happens to bone-deformed objects. Is it just because the polys are non-planar? And when I scroll through the frames the un-rendered polys come and go and others that weren't missing suddenly go, and come back. I realize this is probably an Open-GL thing. Is there a way to fix it? I see it both on Windows & Mac. 2015.3, NVidia 660, 770, & Titan Black (on different machines). I'm not too familiar with NVidia control panel settings...

130881

shrox
11-10-2015, 12:47 PM
A few characters in our project have a medium high "face" poly resolution. Other characters with subpatching don't have this, and it only happens to bone-deformed objects. Is it just because the polys are non-planar? And when I scroll through the frames the un-rendered polys come and go and others that weren't missing suddenly go, and come back. I realize this is probably an Open-GL thing. Is there a way to fix it? I see it both on Windows & Mac. 2015.3, NVidia 660, 770, & Titan Black (on different machines). I'm not too familiar with NVidia control panel settings...

130881

It should still render fine, it's an Open GL issue I believe.

hdace
11-10-2015, 07:33 PM
Yes it renders fine, I'm only interested in animating without this craziness in my darn viewport!

shrox
11-10-2015, 07:47 PM
Yes it renders fine, I'm only interested in animating without this craziness in my darn viewport!

You might check for doubled polys too.

Greenlaw
11-11-2015, 09:04 AM
Coplanar, like Shrox said or non-planar is my guess.

For the first issue, try unifying the mesh and see if it removes anything.

For the second, check your Polygon Statistics for Non-planar and make the selection--is it selecting the 'holes'? If so, you could triple the selection if you wish. That's usually a good idea because this will insure that it renders correctly.

You might also try merging the points. But be careful you aren't merging something that's supposed to be unwelded.

It might possibly be a Vertex Normal Map issue. If you see one enabled in the Surface Editor, try disabling it. Sometimes these maps can do funky things to the mesh in LightWave.

G.

hdace
11-11-2015, 01:53 PM
It's definitely not Modeler issues. The problem goes away if there are no bone deformations. There's no Coplanar/duplicate polys. Only a few non-planar polys but planar polys disappear too. No unmerged points, no vertex normal map. Don't want to triple if I don't have to. If you look at the image, the head is not being deformed at all, and yet polys one side are disappearing but not on the other side.

I've known all along that it's an Open-GL problem. What I'd like to do is adjust the settings in the Nvidia Control Panel. But I wouldn't know where to start.

shrox
11-11-2015, 02:50 PM
It's definitely not Modeler issues. The problem goes away if there are no bone deformations. There's no Coplanar/duplicate polys. Only a few non-planar polys but planar polys disappear too. No unmerged points, no vertex normal map. Don't want to triple if I don't have to. If you look at the image, the head is not being deformed at all, and yet polys one side are disappearing but not on the other side.

I've known all along that it's an Open-GL problem. What I'd like to do is adjust the settings in the Nvidia Control Panel. But I wouldn't know where to start.

A problem in that it's a Open GL bug apparently, or a feature.

Greenlaw
11-11-2015, 02:58 PM
Very curious. Have you tried an nvidia driver update?

Can you upload a small section of your mesh that has some of the offending polygons? It will probably go away when you cut it out but if not, I'm curious to check it out. If you can also include a screen cap of your Layout GL panel settings, that might help too.

G.

Cageman
11-11-2015, 03:53 PM
I saw this a lot in OpenGL on MDD-deformed characters that were x number of meters away from origin. I can't remember how far away though.

Is your character far away from origin?

EDIT: That said, rendering was never a problem and since we animated in Maya, it was a non-issue... But I can understand your frustration.

hdace
11-11-2015, 05:02 PM
Congratulations Cageman, you get the prize. This particular scene has 5 characters all of whom are about 100 meters from the origin. When I moved one of them back to the origin the holes immediately disappeared.

Yeah it's just a nuisance. I've seen this a hundred times on this project but rendering is never affected. This is a big film with lots of big sets with characters often far from the origin and sometimes it just makes it hard to pose when I can't see the character's body clearly.

Greenlaw: Not sure there's much point in sending you the screen capture since my Nvidia control panel is at its default settings. Whatever shouldn't be at default is what needs to be changed! But alas I assume there's nothing to be done... Thanks for trying guys!

hdace
11-12-2015, 10:23 PM
Since I started this thread I've become more conscious of this phenomenon despite the fact that I've been noticing it for a couple of years now. There are a couple of things I said above that aren't true. This CAN happen to subpatched objects, but randomly. If a character has got subpatching turned off (i.e. set to 0) it usually makes the holes go away, but I've now noticed a couple of objects that were subpatched that did get holes (even at setting 3). Also, It can even happen to objects that are NOT being deformed by bones.