PDA

View Full Version : Bullet Dynamics, Forcefield not working in 2015.3



jboudreau
10-23-2015, 09:41 PM
Hi Guys

I just tried loading the Force_Field_Vortex.lws scene which can be found in the following directory of the 11.5 content folder

C:\LightWave_11_5_Content\Bullet_Dynamics\Forces\F orce_Field_Vortex\Scenes

The force field and vortex effect does not work. I even tried creating it from scratch following codey's lightwave tutorial which can be found here

https://www.lightwave3d.com/learn/article/lightwave-115-forces-tutorial/


https://www.youtube.com/watch?v=tyYzvmJokYU

Are other users aware that this does not work in the latest versions of lightwave 2015.1-2015.3 but works in lightwave 11.6.3?

Thanks,
Jason

nez
10-24-2015, 04:13 AM
Working on 11.6.3 but had 2015 installed to test new stuff and yup, same happens. No problem with 11.6.3 kinda weird.

DogBoy
10-24-2015, 06:45 AM
They work, but the values have to be set much, much higher. Seems like scales changed drastically.

jboudreau
10-24-2015, 07:02 AM
They work, but the values have to be set much, much higher. Seems like scales changed drastically.

Thanks DogBoy, That worked perfectly. Really appreciate the help. Was their any documentation that you know of stating that the scales had changed this much in lightwave 2015.

Jason

jboudreau
10-24-2015, 07:43 AM
TIP: If you want your parts object (boxes for example) to stop moving at the beginning, Which they still do in the video above even after Cody sets it to start on last key frame. Set your glue strength for your parts to 1% and set you breaking angle to 0.1. This keeps the boxes completely still and still allows you to have them break apart saving you from using the start on last key frame.

Hope this helps

Thanks,
Jason

DogBoy
10-25-2015, 05:53 AM
Thanks DogBoy, That worked perfectly. Really appreciate the help. Was their any documentation that you know of stating that the scales had changed this much in lightwave 2015.

Jason

Not that I'm aware of. I just thought I'd check this and noticed something was happening, but not as much as you'd expect so I played with values. As Cody points out, his values are very low, so maybe LW3DG got a bug report saying Bullet was too finicky ;)

Greenlaw
10-25-2015, 12:18 PM
Glad you got that sorted out.

I was puzzled when I saw the above because I was using Bullet Forces in 2015.3 at work this week for a whirlwind effect (similar to the effect I set up a couple of years ago for 'B2' using 11.5) and it worked perfectly fine.

If you see weird stuff happening with old LightWave scenes when using a newer release of LightWave, you should check the tools using newer content first before assuming the newer software is at fault. For example, Bullet and FiberX in recent versions had undergone some drastic internal changes and improvements for new features, accuracy and stability--this is great of course but be aware that it means some older scene files may no longer be valid.

G.