PDA

View Full Version : Normal Map Issues with Global Illumination



gamedesign1
09-27-2015, 08:26 AM
Hi all

I am not sure if anyone else has the same issues with Lightwave as me with Normal Maps when in bounce light situations.
If you look at the image below you can see the normal map works perfectly when in direct light. But in the areas where it is in shadow with bounced light all you get are some highlights. There is no depth/shading.
129968

I have done a similar scene in Modo and the Normal Map works so much better. There is shading and depth as you would expect. See below
129969

Is this a known issue with Lightwave? It is just odd that Modo handles this so much better.

Any suggestions would be greatly appreciated :)

Thanks

dpont
09-27-2015, 10:13 AM
Did you check "Use Bumps" in the Global Illumination panel?

Denis.

Waves of light
09-27-2015, 10:38 AM
Does setting the Colour Space RGB from default to 'Linear' for your normal map in the Image Editor rectify this?

gamedesign1
09-27-2015, 10:46 AM
Thanks for getting back to me dpont.

Yes I had missed that one. It now renders the bumps form the Normal map, thanks.
The normal map was still causing highlights to appear even when there was no GI set on the scene, which I found if I dialed the Amplitude back it would stop that.

Thanks for your help :)

Waves of light
09-27-2015, 10:49 AM
Check your Mipmap settings too. Sometimes having that on can remove bumps from your resulting renders.

gamedesign1
09-27-2015, 10:52 AM
Hi Waves of Light, Changing that setting didn't seem to make any difference. I find it very strange that I have to dial back the normal Amplitude to stop extreme highlights appearing even when in the dark when GI is not set.

Waves of light
09-27-2015, 10:56 AM
How did you create your normal maps, which software package?

gamedesign1
09-27-2015, 10:57 AM
Here's an example of what I mean. There is no GI setup in this version of the scene and there is only one light pointing towards the room from outside and through the window area. So why does the normal maps create highlights on the raised areas when there is no light hitting it? Very strange. I end up having to dial back the Amplitude depending on the lighting to stop it from happening. Its like a clipping is occurring. This issue doesnt come up in Modo.

129971

- - - Updated - - -

I create my normal maps with Quixel

Waves of light
09-27-2015, 11:05 AM
Ok. I use 3DCoat for my normal maps, and when they are brought into LW, I have to invert on the Y, when using the NormalMap node:

129972

Does this help?

gamedesign1
09-27-2015, 11:24 AM
Waves of Light, no that doesn't help the problem. The normal map is fine in terms of the direction. It just seems that Lightwave has a problem when the amplitude setting or the normal map height goes over a certain point. I'm pretty sure it's a fault with Lightwave (I wish it wasn't and it was something I'm doing wrong). IMO the normal map should show nothing at all in the dark no matter how high the bumps are. I shouldn't have to set the Amplitude when using different lighting, just seems a bit strange. Please keep the ideas coming though as I really want it to be something I am doing wrong. I don't want to have to move away from Lightwave because of this issue.

gamedesign1
09-27-2015, 11:35 AM
I just noticed that the problem still occurs when using built in 3D textures if you push the bump amplitude over 100%
So its deffo something to do with clipping. WHen a bump is higher than a certain point whether you set in the Amplitude or it is in the Normal map, the highlights start to go show in the dark. Which is also making it look wrong when in shadow areas when using GI. I have just tried to increase the bump height in Modo to try and cause the same issue and it doesnt happen.

gamedesign1
09-27-2015, 11:43 AM
Does this not happen for you guys?

Nicolas Jordan
09-27-2015, 12:00 PM
The highlights on bump maps appearing in shadowed areas is a huge issue in Lightwave. I come across it all the time. The only solution I have fund is to turn on "double sided" in the surface editor for all surfaces that are having this issue and that usually fixes it. Turning on double sided can cause faceting to show up in shading especially with any surfaces that are using smoothing it will look like smoothing has been turned off.

gamedesign1
09-27-2015, 12:19 PM
That is crazy! Lightwave has been around for years and yet this issue still exists. Modo doesn't have this problem at all :(
I am thinking of moving to Modo, purely based on this problem.

Sorry Newtek, I really have tried to stick with your guy's software because I love its interface and minimalistic layout, but the issues with bump highlights and also the lighting issue of transparency not showing correctly in the VPR really does put me off now. Are these issues really unsolvable?

lightscape
09-27-2015, 12:45 PM
Post the scene.

gamedesign1
09-27-2015, 01:17 PM
Here is the scene http://www.filedropper.com/normaltestlw

gamedesign1
09-27-2015, 01:23 PM
Here is the scene http://www.filedropper.com/normaltestlw

Trev.T
09-27-2015, 01:27 PM
does giving the room thickness work?

Nicolas Jordan
09-27-2015, 01:36 PM
Sorry Newtek, I really have tried to stick with your guy's software because I love its interface and minimalistic layout, but the issues with bump highlights and also the lighting issue of transparency not showing correctly in the VPR really does put me off now. Are these issues really unsolvable?

Try turning off "draft mode" in VPR and see if that fixes the issue with transparency in VPR. And yes bumps render exactly as you would expect in Modo without having to turn on double sided!

gamedesign1
09-27-2015, 01:59 PM
does giving the room thickness work?
the room does already have thickness

gamedesign1
09-27-2015, 02:02 PM
Try turning off "draft mode" in VPR and see if that fixes the issue with transparency in VPR. And yes bumps render exactly as you would expect in Modo without having to turn on double sided!

Turning off draft mode in VPR doesn't solve the other issue. Its a lightwave bug. If you put a light inside an object with a semi transparent surface and using GI, the lighting that is rendered in VPR is not the same as the final render. Give it a go and you'll see what I mean.

The Final Render is darker. If anything draft mode is closer to the final render.

spherical
09-27-2015, 05:01 PM
Check this recent thread:

http://forums.newtek.com/showthread.php?148023-LampLight-VPR-and-Final-renders-how-would-you-solve-this

On the original issue, have you filed a bug report through your account page?

jboudreau
09-27-2015, 05:26 PM
Hi all

I am not sure if anyone else has the same issues with Lightwave as me with Normal Maps when in bounce light situations.
If you look at the image below you can see the normal map works perfectly when in direct light. But in the areas where it is in shadow with bounced light all you get are some highlights. There is no depth/shading.
129968

I have done a similar scene in Modo and the Normal Map works so much better. There is shading and depth as you would expect. See below
129969

Is this a known issue with Lightwave? It is just odd that Modo handles this so much better.

Any suggestions would be greatly appreciated :)

Thanks

Hi

You can also do one of the following things to fix your issue

Take your model and add a .1mm thickness to it using the thicken tool. This fixes your issue and no need to use double sided material. (probably because you are actually making it double sided this way)

or

click on the details tab go under polygons more and click double sided

I'm not sure why you have to do this but it does work

Hope this helps

Thanks,
Jason

gamedesign1
09-27-2015, 06:27 PM
Hi

You can also do one of the following things to fix your issue

Take your model and add a .1mm thickness to it using the thicken tool. This fixes your issue and no need to use double sided material. (probably because you are actually making it double sided this way)

or

click on the details tab go under polygons more and click double sided

I'm not sure why you have to do this but it does work

Hope this helps

Thanks,
Jason

My Model isn't using a double sided surface, it has thickness already. I just created a box room again with .1mm thickness and the problem still exists. Thanks for the suggestion though.

gamedesign1
09-27-2015, 06:29 PM
Check this recent thread:

http://forums.newtek.com/showthread.php?148023-LampLight-VPR-and-Final-renders-how-would-you-solve-this

On the original issue, have you filed a bug report through your account page?

Thanks for the link.
Yeah I have posted a bug report to newtek today. I am not sure if its something they will correct though, as it has been an issue of Lightwave's for a long time.

JoePoe
09-27-2015, 06:33 PM
click on the details tab go under polygons more and click double sided

I'm not sure why you have to do this but it does work

Hope this helps

Thanks,
Jason

This does seem to work :thumbsup:.... but it's HILARIOUS.
Click on a buried sub catagory menu item "double sided" in order to avoid making the surface ..... double sided. :bangwall:

:ohmy: I laugh so as not to weep.

jboudreau
09-27-2015, 06:38 PM
My Model isn't using a double sided surface, it has thickness already. I just created a box room again with .1mm thickness and the problem still exists. Thanks for the suggestion though.

Hi

It works if you follow my steps

Try this scene file. Let me know what happens

129974

As you can see from the image below it works, no double sided material

129975

Thanks,
Jason

jboudreau
09-27-2015, 06:39 PM
This does seem to work :thumbsup:.... but it's HILARIOUS.
Click on a buried sub catagory menu item "double sided" in order to avoid making the surface ..... double sided. :bangwall:

:ohmy: I laugh so as not to weep.

haha, I know crazy hey, but it does work lol

Thanks,
Jason

jboudreau
09-27-2015, 06:48 PM
Thanks for the link.
Yeah I have posted a bug report to newtek today. I am not sure if its something they will correct though, as it has been an issue of Lightwave's for a long time.

In regards to using the thicken, You have to click on the thicken tool and drag your mouse to add some thickness, Then press n on the keyboard and type in .1mm and press enter then drop the tool with the space bar.

Save you object and your issue should be fixed

Thanks,
Jason

JoePoe
09-27-2015, 07:08 PM
More of the same right? Add thickness to something that already has thickness.

It may, in the end, give the desired result, but boy that's a whole lotta wrong.

(don't get me wrong. I appreciate the problem solving :))

jboudreau
09-27-2015, 07:21 PM
More of the same right? Add thickness to something that already has thickness.

It may, in the end, give the desired result, but boy that's a whole lotta wrong.

(don't get me wrong. I appreciate the problem solving :))

Oh yeah I know it's wrong in so many ways and is definitely a bug that the LW team needs to fix.

But when it comes to lightwave sometimes you have to do whatever you can to get the results your looking for

Thanks,
Jason

JoePoe
09-27-2015, 07:29 PM
.....But when it comes to lightwave sometimes you have to do whatever you can to get the results your looking for

Thanks,
Jason

Definitely! :lightwave :dance:....... ;D.

djwaterman
09-27-2015, 08:33 PM
Wow, this is embarrassing, LWG please fix it.
Also set the normal map to linear in the image settings, it doesn't fix this problem but that's the standard setting for normal maps.

lightscape
09-27-2015, 10:19 PM
Definitely report it.
Its a bug I've not noticed with some old habits I do in lw. I turn on double sided for archi stuff especially models from sketchup because I'm lazy.

dpont
09-28-2015, 12:24 AM
Undesired bump diffusion effect in shadowed areas
can be controlled with Bump Dropoff.

Denis.

gamedesign1
09-28-2015, 07:44 AM
Hi

It works if you follow my steps

Try this scene file. Let me know what happens

129974

As you can see from the image below it works, no double sided material

129975

Thanks,
Jason

Yeah that does seem to help that weird highlight problem. But when you turn on GI you still end up and turn up the intensity of GI you get a very weird spread of light and highlights around the window area. It just doesn't react like it should.

129996

- - - Updated - - -


More of the same right? Add thickness to something that already has thickness.

It may, in the end, give the desired result, but boy that's a whole lotta wrong.

(don't get me wrong. I appreciate the problem solving :))

I agree with you, you shouldn't have to mess about doing things like this.

gamedesign1
09-28-2015, 07:50 AM
I am finding less and less reason to stay with Lightwave for my projects. The main reason I have stayed with Lightwave is because I really like the separation of Modeler and Layout, but Modo really does a good job of doing the same thing with Import Reference now. Also the bones system seems very clean in Lightwave, but Modo is getting better and better at that stuff too. I think Newtek really needs to up their game to stay in the competition. Its a real shame because I really love the feel of Lightwave.

lightscape
09-28-2015, 11:07 AM
I am finding less and less reason to stay with Lightwave for my projects. The main reason I have stayed with Lightwave is because I really like the separation of Modeler and Layout, but Modo really does a good job of doing the same thing with Import Reference now. Also the bones system seems very clean in Lightwave, but Modo is getting better and better at that stuff too. I think Newtek really needs to up their game to stay in the competition. Its a real shame because I really love the feel of Lightwave.

I guess you haven't heard what 901 is like? :D
I'm sticking with 801. 901 is a disaster.

bobakabob
09-28-2015, 11:49 AM
Thanks for highlighting this. But all software reveals embarrassing bugs over time.
Right now Maya 2016 (after so 2 and 3) for example cannot load scenes with animated referenced characters. This is a disaster for economical character animation production - everything Maya is known for - and still no fix after all the complaints. I've lost days of work after installing dodgy updates and trying failed workarounds. A personal thing but don't judge LW too harshly. The Dev team do listen and usually LW is pretty solid and reliable.
There's also no reason why Modo and LW shouldn't coexist. And have you seen the latest from Rob Powers?

MSherak
09-28-2015, 04:46 PM
Yeah that does seem to help that weird highlight problem. But when you turn on GI you still end up and turn up the intensity of GI you get a very weird spread of light and highlights around the window area. It just doesn't react like it should.

129996

- - - Updated - - -

Well you should be in the right colorspace first, you're scene is set to Linear. Set CS to sRGB and set the normal map image to linear. Then set the Bump Dropoff to 100%. Hit F9 and it will render correctly even if you have a smoothing angle of 89.5. No double side needed. You can even shoot up the normal map now and it works just fine. The weird highlight around the windows is due to the light bouncing off the bottom and left edges and lighting up the bump on the other sides. You go to a higher bounce count you will see that the top and right side will start to light the bottom up. It is correct.


I agree with you, you shouldn't have to mess about doing things like this.
You don't.


This is not a bug at all. LW allows you to control your dropoff. Just need to use the button. (the render below, CS srgb, single sided, non-thickened, walls with the dropoff set to 100% and normal at 200%.)

-M

gamedesign1
10-07-2015, 09:20 AM
Thanks for your reply, the Bump Dropoff is exactly what I was looking for :) Sorted it right out. I don't agree that the circle of light around the window is a normal effect of light bouncing around. I know its not physical based lighting in Lightwave, but I still haven't ever seen this effect on any other software I have used. Thanks a lot for all your help though (Y)