PDA

View Full Version : TEENSY thing: the "v" in the version number



jeric_synergy
08-30-2015, 06:41 PM
OK, this is preeeeety picayune, but:

The auto-incrementer puts a '_v' in the increment number automatically. Now, I've often complained about how many areas of LW don't allow enough space for object names as it is, do we really need that 'v' in there?

Every4thPixel
08-31-2015, 04:27 AM
Yes!

jeric_synergy
08-31-2015, 08:21 AM
Ummmm, "Yes we need the v" or "Yes, please get rid of the redundant thing"?

Greenlaw
08-31-2015, 09:05 AM
I agree--many of the studios where I've worked don't use the 'v' and I don't use it for my personal projects either. It's the reason I don't use this feature. I like the name to be descriptive but also as concise as possible. If you have a clear naming convention and use it consistently, the 'v' should be redundant.

The user/studio should be allowed to define naming conventions. There should be an option in Preferences for scene name or version name format.

Not a huge deal but it would be nice.

G.

jeric_synergy
08-31-2015, 09:31 AM
Not a huge deal but it would be nice.
G.
Yeah: always seemed a bit high-handed to me. And a little dumb.

Every4thPixel
08-31-2015, 10:18 AM
Yes we need it. I think it's handy to see if it's a frame range or a version number.

jeric_synergy
08-31-2015, 10:28 AM
Wouldn't you rather it be user-definable?

Anyway, I'm w/Greenlaw.

Greenlaw
08-31-2015, 10:32 AM
The number of zero places should be definable too. For me, two places is plenty--in the many years I've been doing this for a living, it's been extremely rare for me to exceed 99 versions of anything. I think if I can't get it right before then, then I'm probably doing something very wrong. (That or I"m dealing with an incredibly indecisive client.) :p

G.

jeric_synergy
08-31-2015, 10:47 AM
Inside my head, that (leading zeros) was a given. --So many tiny things that would add up to a much nicer user experience.

To flesh this out: As a feature, this would allow users to specify leading text, including none; leading zeros;, and the type of ordinal designator ;) : integers, alphabetical, or hexadecimal. :D

Also, dates, and their various formats.

ernpchan
09-08-2015, 08:52 AM
Or just script your own incremental saver.

Greenlaw
09-08-2015, 09:49 AM
Hmm....are you saying this might be a good practice project? :)

spherical
09-08-2015, 05:49 PM
Hmm....are you saying this might be a good practice project? :)

There's already a number of plugins that allow customization in one way or another; either by preference setting or editing the code. Having the internal function operate in a more intelligent manner would of course be preferable, but.....