PDA

View Full Version : LW 7.5 update install problem?!



brandon
03-06-2003, 10:15 AM
Hi everyone, I am new to lightwave (just got 7 a bout 1-2 weeks ago) and i noticed that NewTek has a free update to 7.5 on their site.... so i downloaded it, but it wont install.

Here is the problem: When i dbl click the .exe everything unpacks and then ms installer starts up, but then closes and gives me the following msg- " ERROR 1608: Failed to Create Install Driver Instance" - I am using w2k w/sp2 ntfs (if more sys info is required just ask).

I did a search on google for that error and tried the different fixes, but none worked. Every other program i have installs just fine, even lightwave 7. its just the 7.5 update giving me this error.

I even tried a w2k repair, but no go. I really dont want to have to format and install again :(

Thanks in advance for any and all help :)

WCameron
03-06-2003, 11:27 AM
i think this is a broken download, or a broken installer
error.

try this:

Select the exe file, right click on it and Extract it to a directory.
move into the directory and try installing it from there instead of
letting it happen automatically from a temp directory.

sometimes that works.

otherwise possibly redownloading it again might help.

- Will.

brandon
03-06-2003, 12:00 PM
Thanks, i never thought to try it that way.

brandon
03-06-2003, 01:41 PM
Well, i called mt girlfreind(she is at home today) and walked her through Wcameron's suggestion. still got the same error. So i told her to delete them and redownload the update, and try again, but it still gave the same error :(

Stewpot
03-06-2003, 03:32 PM
Hi

Make sure you don't have the hub running. This caused a problem for me.

3D|Dave
03-07-2003, 12:19 AM
I found that the update needs to "see" a local C drive or it errors out. Could this be the case?

brandon
03-07-2003, 09:52 AM
3D|Dave: What do you meen by "see" a local C drive?

Stewpot: Hub is not running during my install attmpts. But thatnks for the advice :)


Problem still persists... but it is not that big a deal.

I am perfectly happy running 7, but i figured since the update is free, why not?

WCameron
03-07-2003, 03:04 PM
Its an install sheild error.

-- begin inclusion --

Cause
Error 1608 is a generic error thrown by Setup.exe. The occurrence of this error message is uncommon and is system specific. Listed below are some common causes or instances known to occur in case of this error. The pertinent resolutions are listed in the next section. InstallScript Engine installation may have failed causing the engine to not install properly.

Dcom Configuration may have limited access, causing setup to fail while creating an instance of the IDriver object.

The operating system may be corrupt or outdated.

Setup may fail due to an older version of InstallShield Express 3.x that failed to uninstall during the upgrade to InstallShield Express 3.5 SP4.

Lack of sufficient privileges on the machine.

On Windows 98, Dcom98 may need to be updated or installed.




Resolution
Listed below are possible solutions or steps to eliminate the error message. Launch the file Iscript.msi file, which should in the same directory as the InstallShield Express 3.5 SP4 setup. This launches the InstallScript engine installation separately. Run the InstallShield Express setup again after running Isscript.msi.

On some machines, the Dcom Configuration may not be set properly. Follow the steps below to set the appropriate settings. This is only for Win NT/ Win 2000 or Win XP machines.
Launch the utility DCOMConfig by typing "dcomcnfg" in the Windows Run dialog.
Select the Default Security tab.
Click Edit Default in the Default Access Permissions section.
Ensure that "Allow Access" permissions is selected from the drop-down box.
Click OK in the utility and re-run the InstallShield Express setup.



Run the latest service pack for Internet Explorer or the operating system.

Uninstall or remove all instances of previous versions of InstallShield Express 3.x. If the InstallShield Express 3.x installation is left suspended, causing it to not completely uninstall, you can use MsiCleanUp Utility to clean the system. You can download MsiCleanUp Utility from Microsoft's Web site at http://support.microsoft.com/support/kb/articles/q238/4/13.ASP.

In order to run InstallShield Express 3.5 SP4 setups on Win NT/2000/XP machines, users need administrative privileges.

Download Dcom98 for Windows 98 from Microsoft's Web site and install it on the machine. Refer to the following link to Download Dcom98: http://www.microsoft.com/com/dcom/dcom98/dcom1_3.asp.

Note: In addition to above, make sure that the Temp directory is clean and no application or service is running in the background.

-- end inclusion --


- Will.

ncritten
03-07-2003, 05:06 PM
I assume you are trying to install the new 7.5b patch, so if you are running LW7 then that will be the problem the installer only upgrades 7.5 installs.

Grab the 7.5 upgrade first

Nigel

brandon
03-08-2003, 10:20 AM
ncritten: i am installing the 7.5 not the 7.5b. it is not a case of having the wrong update, it is a case of the install engine not loading.

WCameron: tried the suggestions you posted, and nothing helped, i even decided to format and reinstall windows.... and i still get the same problem.... i give up anyhow, its not a big deal.


Thanks everyone for your help :)

Freak
03-08-2003, 06:03 PM
Why are you using SP2? try loading SP3 or SP4
Try removing Dcom from services or task manager...

You are logged in as Admin aren't you?
remove anything that is not needed, virus scanners etc...
(anything not vital to system)

MSI files are a major step backwards, and always cause problems.

Good luck..

Hope it helps...

brandon
03-09-2003, 05:18 PM
just to keep everyone who offered help updated. I went for a re-install of w2k and decided to go with FAT32 for the file system, since my other drive is also FAT32, and guess what! 7.5 installs without a a problem now.... go figure?!

Anyway, thanks everyone for all the help :)