View Full Version : Surface library problem

07-30-2015, 06:45 AM

I import lots of OBJ's, fix the surfaces and save them as a surface library (right click on object in surface editor and "Save library"), so far this has worked fine but today I got all surfaces messed up pretty bad, the surface parameters is pretty much ok, but it has the wrong texture maps assigned to the surfaces (they are swapped around), it's all messed up and LW crash often after I load the library also.

I tried to save the library again in case it got corrupt but same problem, the weird thing is that if I use the .lwo object instead (that is the fixed OBJ object), save the surface library and just load it back into the same object again it is already there all messed up.

It works with most other objects so there must be something in this object that cause the problem, but I do not know what that could be, anyone else had the same problem maybe ?

LW 2015.2 Win64

07-30-2015, 06:57 AM
Ah, maybe there is some problem with the OBJ file that follow it into LW, I just noticed that some of the textures in the surface library are textures that should not be in the OBJ file, those parts have been deleted from it so maybe there are some artifacts left in the OBJ that mess everything up, so forget about it for now.

07-30-2015, 03:08 PM
It look like there might be some bug in the code that saves the surface library, I am not 100% sure but I think it is actually updating the library file if it already exists, so if you overwrite with a smaller file it will be corrupt, the only way I could get it to work was to delete the old .lib file and then save it and suddenly everything worked fine again, so be careful if you overwrite a .lib file.