PDA

View Full Version : Instances place vary betewen VPR and Render



Roque
07-12-2015, 05:00 PM
Hi, I have instances distributed on surface of an object, in surface mode.
But this distribution is different in VPR that in render.

I can fix this distribution? like can fix particles save pfx.

Thanks,
Roque

Ma3rk
07-12-2015, 07:50 PM
Is your instance visibility option set to 100% ? VPR might simply not be able to display them all as well. What do things look like in wire frame?

Roque
07-12-2015, 09:17 PM
Yes is set 100% and in wire frame too, both showing same, but if I do F9, there are another disttribution.
In particles, the same thing happen, but saving pfx, you can fix that.

Greenlaw
07-12-2015, 10:21 PM
When using Surface mode, I'm getting the identical distribution of instances when comparing OGL, VPR and f9. Running 2015.2 on Windows 8.1.

Can you post screen caps and maybe the scene?

G.

Greenlaw
07-12-2015, 10:29 PM
I tried a bunch of variations (subpatch off and on, displaced surface, random and uniform settings, single and multiple source, etc.,) and distribution between OGL, VPR and f9 was consistently identical each time.

I hope this doesn't sound too basic but is your view set to Camera or Perspective? If it's Perspective, maybe the angle is different enough to make the distribution appear different from the f9, which always renders Camera view. Just want to get that possibility out of the way before looking deeper.

G.

dpont
07-12-2015, 11:58 PM
If your object is subpatched,
you may have different preview (VPR) and render (F9) subdivision level,
in this case surface distribution gives different results
because it is based on the geometry.

Denis.

Roque
07-13-2015, 04:23 AM
If your object is subpatched,
you may have different preview (VPR) and render (F9) subdivision level,
in this case surface distribution gives different results
because it is based on the geometry.

Denis.

This was my problem and now seems obvious :P
Thanks!