View Full Version : Flocking problem

07-10-2015, 06:21 PM
I am back again, sorry! :)

I am pulling my hair out of this and I do not understand why it is happening!

I made a flock of bears in an empty scene and they follow the path correctly, both normal way and the trick with walking on surface (using agentinfo & raycast node), but if I make the flock in my forest scene I created, I made the path like I did normally in the empty scene one and set it all up - at frame 1, all the agents go to position 0,0,0... It does this with all methods; goal, path etc. Can someone tell me why?

I have included images explaining this:


After frame 3, they just float around the centre :/

To make sure I haven't miss something out, I made another blank scene and made the land, added my bears and made the flocking, no problems and it works correctly.

Here is my nodes:


However, it even does that without any nodes on :/ Instead of following a simple path, it just runs to position 0,0,0 and floats around.

07-11-2015, 11:25 AM
You don't mention, but have you done a Calculate all Motions or Full Evaluation from the Flocking pane since bringing everything into the new scene?

07-13-2015, 11:29 AM
Haven't played with flocking in a while, but could this be something to do with autokey?

07-14-2015, 06:53 AM
I solved it, thank you guys :) Something wrong with vector or subtract somewhere around there. I just re-created the nodes and it works now.

I have another question though:

How do I make the agents follow their path accurately? The director always goes faster than the generator, I tried upping the speed and I think that just makes the agents go out even more and I think that causes the agents to go around 10m from the actual path. is there a setting I am missing? I am trying to learn flocking here, and so far, it has been a headache. It is harder than I thought lol.