PDA

View Full Version : Forces with Alzheimer



VirtualFM
06-25-2015, 11:05 AM
Hello!

I don't remember the last time I has to use particles intensively in Lightwave, but I don't remember having this bug (except perhaps some problems when loading from scene)

The problem is that wind forces are forgetting the wind type and other parameters. I add some wind forces (doughnut, vortex, direction, etc) make my experiments and finally get what i want. I save the scene. Then load it again an the particles don't look the same at all. After some head-banging to see what was wrong I found that the wind forces are loosing the following (that I noticed):
- wind force mode (they all default to "direction")
- group (defaults to "<default>")
- falloff mode (defaults to "linear")
- several parameters (predictable, since most are disabled with the "direction" force mode, but could "remember" the parameters when changing to the correct mode again, but doesn't)

In short, I was working on a scene for a whole day, saving versions as I went along, and now I have nothing, as all parameters are gone and this is useless like this. When did this happen? Does anyone remember what was the last version this DIDN'T happen?

prometheus
06-25-2015, 12:03 PM
Hello!

I don't remember the last time I has to use particles intensively in Lightwave, but I don't remember having this bug (except perhaps some problems when loading from scene)

The problem is that wind forces are forgetting the wind type and other parameters. I add some wind forces (doughnut, vortex, direction, etc) make my experiments and finally get what i want. I save the scene. Then load it again an the particles don't look the same at all. After some head-banging to see what was wrong I found that the wind forces are loosing the following (that I noticed):
- wind force mode (they all default to "direction")
- group (defaults to "<default>")
- falloff mode (defaults to "linear")
- several parameters (predictable, since most are disabled with the "direction" force mode, but could "remember" the parameters when changing to the correct mode again, but doesn't)

In short, I was working on a scene for a whole day, saving versions as I went along, and now I have nothing, as all parameters are gone and this is useless like this. When did this happen? Does anyone remember what was the last version this DIDN'T happen?

it happened a few versions ago and forth:D
now..how do we solve that?
well you could provide info on what lightwave version you are using:D it is likely no one will care checking out whatīs wrong without such info.

MSherak
06-25-2015, 12:19 PM
If you have 2015 there was a bug with ParticleFX. The hotfix is in your account downloads.

prometheus
06-25-2015, 01:36 PM
If you have 2015 there was a bug with ParticleFX. The hotfix is in your account downloads.

I had no issues with just testing a vortex wind and a dounut wind with particles...reloaded fine in lw 11.6.3 so it may be the 2015 bug...if thatīs what he used.

VirtualFM
06-25-2015, 02:34 PM
I thought it could be deducted from my words and context that I was using the latest version. But anyway, yeah, this was in version 2015.2.

Thank you MSherak, will look into this hotfix.

Glad that you checked it, Prometheus, it's good to know I am not crazy and that this worked properly before.

Anyway, in the meantime I digged version 2015.1 and reinstalled it, and there the scenes work fine. Pity 2015.1 has some OTHER bugs. Will have to make some tests to see wich walls I'll run into if I go the downgrade route. But I will only do that after checking if that hotfix fixes it!

Thank you!

prometheus
06-25-2015, 03:42 PM
I thought it could be deducted from my words and context that I was using the latest version. But anyway, yeah, this was in version 2015.2.

Thank you MSherak, will look into this hotfix.

Glad that you checked it, Prometheus, it's good to know I am not crazy and that this worked properly before.

Anyway, in the meantime I digged version 2015.1 and reinstalled it, and there the scenes work fine. Pity 2015.1 has some OTHER bugs. Will have to make some tests to see wich walls I'll run into if I go the downgrade route. But I will only do that after checking if that hotfix fixes it!

Thank you!


Hope you will solve it with the bug fix.

and no no no...Impossible to read out from the words or context you were using the latest version, if the reader is a woman..it is however possible to read between the lines, and also implement other things not there :D

Since I am a male, my simple brain couldnīt figure that out.

cheers.

Michael

spherical
06-26-2015, 12:00 AM
and no no no...Impossible to read out from the words or context you were using the latest version, if the reader is a woman..it is however possible to read between the lines, and also implement other things not there :D

Since I am a male, my simple brain couldnīt figure that out.

Michael, you made my week! Nearly passed a mouthful of chardonnay through my nose....

prometheus
06-26-2015, 09:48 AM
Michael, you made my week! Nearly passed a mouthful of chardonnay through my nose....

Lol...chardonnay should go through the throat, not the nose :D
I am glad to encourage to new bold experiments though.

VirtualFM
06-26-2015, 10:14 AM
Hope you will solve it with the bug fix.

and no no no...Impossible to read out from the words or context you were using the latest version, if the reader is a woman..it is however possible to read between the lines, and also implement other things not there :D

Since I am a male, my simple brain couldnīt figure that out.


Haha! That was fun!

But look, since we are both males let's analyze the issue logically! :-) In the last sentence I said "When did this happen?", which means there was a time this did NOT happen, when using some older version than the version I was currently using. OK, at this point you know that it happens with the version I am using but with some older version it was not happening, however you still have no idea which version I was using, but right after that I added "Does anyone remember what was the last version this DIDN'T happen?". So there is a timeline, and we will need to start to examine the timeline backwards. Since I am asking when was the last version this DID NOT happen, it means that in the latest version, this actually happens, and that's obviously the version i was using.

Anyway :-)

The hotfix fixed it. The saved scenes are loading with the wind type and parameters intact. Thank you so much for the replies.

prometheus
06-26-2015, 02:05 PM
Haha! That was fun!

But look, since we are both males let's analyze the issue logically! :-) In the last sentence I said "When did this happen?", which means there was a time this did NOT happen, when using some older version than the version I was currently using. OK, at this point you know that it happens with the version I am using but with some older version it was not happening, however you still have no idea which version I was using, but right after that I added "Does anyone remember what was the last version this DIDN'T happen?". So there is a timeline, and we will need to start to examine the timeline backwards. Since I am asking when was the last version this DID NOT happen, it means that in the latest version, this actually happens, and that's obviously the version i was using.

Anyway :-)

The hotfix fixed it. The saved scenes are loading with the wind type and parameters intact. Thank you so much for the replies.

Are you married and had your wife sneaking behind you:D or are you a beer drinker?
you do know it contains female hormons?, all that could explain the.."read between the lines syndrome" :D
I am not married, no girlfriend and a I am no beer drinker.
I could neither slay the The Witch-king of Angmar nor can I read between lines to acknowledge what is not there, maybe thatīs why I donīt have a girlfriend? :D

Seriously, one could suspect you would have some later version, but not for a fact determine that you actually had the last version.

The qoute..
"Since I am asking when was the last version this DID NOT happen, it means that in the latest version this actually happens,"
This seems a bit in accurate, it can mean the 2015 version, But it can mean it happens in lw 11.6.3 as well, who says it could not have been an issue in there? for all of us"

I donīt know...maybe I should go and get a beer to understand all this:D

straight to the point, I am being silly...and you donīt have to read that between the lines, I am giving you that straight up.

Glad you solved it anyway, and it helps being aware of the Real issue with particleFX.
I think I am known to have a bit of a backwards logic or warped mind in some circumstances, so it would be interesting to hear others opinion about me
not able to interprete the lines correctly, hope you havenīt been too offended with me pointing to the "what lw version it is"