PDA

View Full Version : IK Rig Snapping problem



short223
06-24-2015, 01:08 PM
I have a very small character with an IK rig on his leg. The issue I am having is between single frames when the Root Control Object moves down, the bent knee will "snap" straight, and the goal object is displaced. (see attached pics).

Not sure if this is a common thing or not but I can't seem to get it to not snap. Any help would be appreciated.

bazsa73
06-24-2015, 02:03 PM
Do you have inverse kinematics on for both leg joints?
Check the motion panel/Controllers and Limits/ Pitch controller. Is it Key Frames or Inverse kinematics?

short223
06-24-2015, 02:36 PM
Inverse Kinematics for both leg joints. It behaves as it should as it was created via a tutorial.

RebelHill
06-24-2015, 03:33 PM
see here...


https://www.youtube.com/watch?v=T2VYPnVIW0Y&index=15&list=PLTds3QePYrWEWipwKkLmyNT4Tf_JTigM2

short223
06-25-2015, 08:29 AM
Knew you would have something. Thanks as always....

short223
06-25-2015, 10:02 AM
I have been able to improve it a bit, but I am rotating on the pitch which could be the main problem. Afraid to change it currently but will look to do so if it becomes too problematic.
I did notice that I was running on 11.6 but accidentally opened it up in 2015 (was an older file). The IK system for the legs didn't work anymore (thought I was going crazy for a bit).

Is this a known bug where IK bones are not working from older files in v2015?

RebelHill
06-25-2015, 11:58 AM
Nope... there's no misbehaviour with IK going between 11<>2015, nor is the fact that you're using pitch necessarily a problem either (certainly not for simpler, properly planar chains). Has to be something wrong with your actual setup.

bobakabob
06-26-2015, 01:02 AM
Or check that you have activate IK switched on - it's a standard button, frequently set to off for some reason and can drive you nuts if you don't know of its existence.