PDA

View Full Version : Objects clipping/disappearing in MODELER



Arch
06-08-2015, 12:29 PM
Hello.

I couldn't find a post about this.

My backdrops, and any objects, clip at some angles or when too close.
I am trying to model this car, a Honda EK9, but my backdrop/polies with blueprints on them keep disappearing when I zoom in to a detailed level.

What could be causing this? There is no min. clip option in MODELER either.

NOT LAYOUT.

Thanks!

128563

Sensei
06-08-2015, 12:38 PM
That's normal. Vertex position is at negative Z-depth to camera..

Arch
06-08-2015, 12:45 PM
So it's normal for my blueprints to disappear, leaving me unable to do any kind of modeling?


Can't I just decrease the minimum distance somehow, or "make the camera smaller"?

I should be able to see in the corner in the picture, for example. Visually.

Do I need to move the whole thing forward or something

spherical
06-08-2015, 12:47 PM
I have my viewports set up so that Perspective has Independent Zoom. Then, when I need to get really close to geometry, I move the other viewport's view centers, so that the object comes closer to the Perspective "camera" in any particular vector I want; depending upon the Perspective viewing angle. Using this method, you can get as close as you want, and closer. Usually, when I go for a particular area, I set the Perspective angle, move the Viewports to effectively "move the part to the camera" in a manner of speaking, and then have to Zoom OUT, because I'm then too close.

(There's gotta be a better way to describe this. Haven't had my double shot espresso yet. Will be back and edit, when my brain starts.)

Arch
06-08-2015, 12:58 PM
The problem is the ortho views, though, with the blueprints.

As I zoom in, whether it's a backdrop or geometry, front disappears first, then side, then top.

So there MUST be a solution, otherwise people can't even work on cars. I can barely see subtle detail with the amount I can zoom in.

EDIT:

See?

128564

128565

Sensei
06-08-2015, 01:04 PM
Restrict view to just a few polygons where you want to work, and press Hide Unselected. But if you have really huge polygons for entire object, this won't work. Divide them, and try.


So there MUST be a solution, otherwise people can't even work on cars. I can barely see subtle detail with the amount I can zoom in.

why? You can make element when everything else is invisible, at any scale. Then scale it down. And at the end, join with the rest of mesh.

Arch
06-08-2015, 01:06 PM
Restrict view to just a few polygons where you want to work, and press Hide Unselected. But if you have really huge polygons for entire object, this won't work. Divide them, and try.



why? You can make element when everything else is invisible at any scale. They scale it down. Join with the rest of mesh.

Tried the first.

Second, what do you mean? Make the blueprints and car huge then scale down?

Sensei
06-08-2015, 01:13 PM
Second, what do you mean? Make the blueprints and car huge then scale down?

If you have empty layer, does backdrop image disappears when you zoom-in? I don't think so.
Simply don't make everything in just one layer.
Make element by element,
piece by piece,
then join in one layer at the end..

I wrote plugin which is helping in making cars,
helping visualizing spline cages:
http://www.easyspline.com

Arch
06-08-2015, 01:17 PM
Yes, my backdrop images do disappear when I have an empty layer.

Only in select cases when I can zoom in on a single spot very accurately does one layer stay.

I cannot get even just the layer I want to stay, even when I zoom into one point when there's anything on the canvas.
Maybe it's my technique, maybe not. Is there no way to just remove this?

Sensei
06-08-2015, 01:23 PM
I noticed something weird on screen-shot from #5 post.

Why you have box with textures with blueprints?

This is not how we do normally in LW.

Press 'd' to Display Options.
Pick up Backdrop tab.
And set backdrop images there..

Backdrop in perspective viewport is useless. Backdrop images should be in orthographic viewports.

That's why we misunderstood each other. While taking about backdrop images with blueprints we thought you're talking about built-in backdrop feature, not box with textures..

Arch
06-08-2015, 01:24 PM
I tried both ways, the 3DS Max way, with the textures, and backdrops.

Backdrops thus far work better, but I'm having a hard time working with them.

It seems to be nearly random when they want to disappear and when not.

So, hide everything except what's being tweaked, zoom tool to zoom into point I am tweaking and it should work?

EDIT: I am talking of both ways, mainly backdrops.

Sensei
06-08-2015, 01:28 PM
If you prefer box with textures instead of built-in backdrop feature,
divide this box to f.e. 100 segments each axis.
Then select a few polys where you want to work,
shift-a to zoom selection,
and hide unselected.

Arch
06-08-2015, 01:29 PM
How would I do it with backdrops then?

The same for the mesh I am working on?

JoePoe
06-08-2015, 01:29 PM
Yes, clearly Arch is coming from other program(s) where the reference images are set up that way.
Arch... in LW we set or reference pics in the backdrop options. It is not geometry.

Regarding clipping:
When that happens I usually just select a part of the geometry (point, edge or poly) I want to get to and hit shift-a. That seems to shake the cobwebs out of modelers clipping brain.

So in your example, I would select the corner point and hit shift-a.

shrox
06-08-2015, 01:29 PM
You can save the backdrops as a cfg. file to load up later.

If your item is far from the origin clipping can be more evident too.

Arch
06-08-2015, 01:31 PM
Shrox, that's not what I'm talking about but thanks, though.

I always forgot to save them until I lost my perfectly aligned and scaled blueprints a few times.

Okay so:

Select, hide unselected, zoom tool, move geometry, zoom out, show everything?

JoePoe
06-08-2015, 01:33 PM
Arch see my post.

(Three posts at the exact same time :D.... never seen that before)

Arch
06-08-2015, 01:37 PM
https://www.youtube.com/watch?v=m9v9fVEQA1w

EDIT: So I guess this means I have it down now?

spherical
06-08-2015, 05:03 PM
Here's an old thread on it that covers it pretty well: http://forums.newtek.com/showthread.php?123358-Clipping-Distance-Modeler Same as described above, but explained in a different manner, which may clear ambiguities.

Also, in Ortho views, the farther away from viewport center your model gets, the quicker the clipping starts. IOW, I just tested: zoomed way out, moved the XZ view (not the model) so that the model was at either the top of the viewport or the bottom of the viewport, then zoomed the XY and the model clipped way earlier. Pull XZ back to center and the zoom goes almost all the way before clipping. So, the advice to hide geo and center in viewports is the way to get it done.

Dexter2999
06-08-2015, 06:01 PM
Okay so:

Select, hide unselected, zoom tool, move geometry, zoom out, show everything?

Keyboard shortcuts are your friend

Select,
"+" to hide unselected,
SHIFT-A to zoom on selected,
CTL+ALT LMB to zoom out when moving geometry,
"\" Show all

Practice, practice, practice and it will become second nature.

Arch
06-08-2015, 09:20 PM
How do I go about binding these to my EU keyboard?

I have keys like /, *, and that are not in use and that I cannot bind anything to.

They'd be ideal to bind these commands onto.

Lewis
06-09-2015, 12:35 AM
Hi Arch!

Check my old video how to setup blueprints in LW (easy/automatic way in proper scale). That should help you to setup Blueprints in LWM. It's LWM 9.6 but still 99% same in LWM 2015.
http://www.foundation3d.com/index.php?categoryid=39&p2_articleid=142

inkpen3d
06-09-2015, 03:12 AM
Okay, maybe I'm being a bit dense here, but I've never quite understood the rationale behind viewport depth clipping in Modeler - at least the way it has (always) been implemented.

I appreciate that it is a way of de-cluttering the field of view (i.e. you don't want geometry behind your point of view being visible) hence you always need "near-depth-clipping". However, "far-depth-clipping" seems to be a relic left over from a time when computers were too slow to manipulate large numbers of polygons and you would want to reduce the computational load on the system. However, it seems to me that this far-depth-clipping is largely redundant nowadays when we've got fast CPUs and GPUs.

As we've all experienced, far-depth-clipping tends to mess with the workflow when you want to repeatedly zoom in on detail. I personally find it a pain in the proverbial - especially given that we don't have any control over the near-/far-depth-clipping distance settings or, perhaps more usefully, have the ability to turn far-depth-clipping off.

If there's some other reason for having far-depth-clipping in Modeler, please enlighten me.

Regards,
Peter