PDA

View Full Version : Surfaces with alpha transparencies not rendering properly



YourMCAdmin
06-05-2015, 10:51 PM
Hey there! Newb to the forum here, and hoping you folks may guide me in the direction I need to figure out what's causing this issue.

A tiny background: I'm working on a Minecraft based animation. So I'm using a lot of imported maps that were converted to .obj and had all of the textures already UV-mapped. All I had to do was turn off the pixel blending for all of the textures. As you may or may not know, Minecraft is verrrry blocky and pixelated, so most textures are just 1m blocks. But some have transparency which is handled with an alpha placed on the transparency channel of the surfaces. (Had to turn off pixel blending for those as well).

Here is where I'm running into a bit of an issue. Some of these objects, specifically "grass" objects, when rendered from far, don't render properly. Instead, where it's supposed to be transparent it just turns to alpha. So when I place a sky background during compiling, it bleeds right through.

Here are some pictures to show you:
Here, you can see the grass through the cop car. You can see the grass in the front is okay, but the grass and leaves directly behind it, alpha is "bleeding" through:
128542

Here is the same image with a red background to show you where the alpha is. The only alpha that SHOULD be there is the tiny bit in the top right corner which will be the sky:
128543

Here is the same part of the scene with the camera moved closer to the grass. Notice here that the grass renders mostly fine. It seems like the more transparency it renders through, the worse it gets.
128541

I have been turning on and off every option in the Render Globals and none of them seem to help. Maybe someone here can point me in the proper direction! Is it a texturing problem? Rendering problem? Both? I don't know! Hahaha.

I'll be glad to screen shot any of my settings upon request.

Thanks so much for taking the time to read this and hopefully helping me too ;)

ernpchan
06-05-2015, 11:34 PM
Have you tried turning up the ray recursion value? Are you sure you're not seeing holes just because you're seeing through multiple objects through the same hole?

meshpig
06-06-2015, 12:11 AM
Have you had a look at clip maps in the object's properties/render pane? You get this same thing when rendering dense foliage.

YourMCAdmin
06-06-2015, 12:56 AM
Have you tried turning up the ray recursion value? Are you sure you're not seeing holes just because you're seeing through multiple objects through the same hole?

Welp! This seems to have fixed my issue! I just had to quadruple the ray recursion and that seemed to make everything all golden!

Thank you so much! I'm sure I'll be back to pester you geniuses with more questions during the production. Hahaha