PDA

View Full Version : Weird Geometry In Sub D



Columbo24
03-28-2015, 03:42 PM
Still having an unexplained problem using band saw or knife tool. I have the pics of the upper arm only. When I bandsaw,knife etc to add geometry to the arm , I get this weird pinched in geometry. (I'm not in Catmull) When I hit tab and go in polygonal mode the geometry looks fine. The statistic panel seems fine(Pics included). Why am I getting this? I've included a pic where I froze the arm and added the kind of detail I want. It will be more precise and detailed,but with out freezing it I'm having a hard time getting that kind of detail and edging in sub-d. That's why I was trying to add more geometry to the arm so I didn't have to freeze it. I could pull the edges closer to help with the detail but I'm getting this weird result. Any suggestions would help. Thanks.
Bill

Snosrap
03-28-2015, 05:00 PM
I occasionally get those too. I think that the merge points command sometimes merges points that are not on top of one another or some other anomaly with the software. You'll have to fix them manually.

jwiede
03-28-2015, 09:52 PM
I occasionally get those too. I think that the merge points command sometimes merges points that are not on top of one another or some other anomaly with the software. You'll have to fix them manually.

Could it have to do with Merge Point's threshold setting? How far apart are the points in question, and how small is the merge threshold? I've seen cases where users don't realize that despite working on a larger-scaled model, they've zoomed in far enough that the points they wished to keep separate fall within the merge threshold.

WilliamVaughan
03-29-2015, 02:46 PM
Looks like merged verts. You wont notice it in Poly mode but in SubD mode it shows up.

JoePoe
03-29-2015, 04:37 PM
Right, so this is what's happened: (the important part is what you've done before the knife or bandsaw :hey:)

In your quest to get a tight edge I suspect you've done a smoothshift with no actual offset.... 127653.

So really all those "shifted" points are right on top of the originals.
(In your pic #4, in poly mode that shift "isn't there" which means it's on top of the other edge loop.)
When you try to bandsaw across them the mesh freaks out and those points merge during the sawing (you haven't actual hit Merge have you).... 127654
Knifing doesn't merge the points but still gives you an ugly double point pinching.... 127655

(I probably shouldn't mention this interesting little exception..... if you select the loop of polys and hit "l" (connect) instead of knifing/bandsawing, it should look fine).
BUT, I don't suggest doing that because points will still be on top of points which ain't good in the long run.

Moral of the story.... when shifting, give it at least some value... no matter how tiny.
Multishift won't let you get away with no value :thumbsup:.

This effect will also happen if you hit "e" (extend) for the selected polys without moving them after.

---------

Edit: to fix your model quickly.... Do a global merge. Delete the resulting 2 point polys. Do your shifts again.