PDA

View Full Version : Geometry turns black when the scene is saved under quad-view



jboudreau
03-19-2015, 10:03 AM
Hi Guys

It Seems like there is a bug when saving a scene with the quad layout view and having the top right viewport set to shaded solid. It turns your object black when opening back up the scene.
Could someone please if they have time try the steps below and see if this is a bug or not. I reported it just in case. It happens in versions 11.6.3, 2015.1 and 2015.2

Steps to re-create the bug

1. Open Layout

2. Create a Sphere object

3. Set the viewports to the quad view

4. Set the left top, bottom left and bottom right viewports to wireframe and set the top right viewport to shaded solid.

5. Now save the scene

6. Clear the scene

7. Now re-open the scene, the object in the top right viewport goes black

Every time you open the scene now it stays black

Workaround FIX

8. Set the top right viewport now to wireframe

9. Save the scene again

10. Clear the scene

11. Open the scene back up again, the object(sphere) is now the default grey material again.

Thanks
Jason

JoePoe
03-19-2015, 10:34 AM
hmmm. confirmed on 11.6.3 mac.

Other Workarounds:

1) toggle subpatches on then off

or

1) surface editor (even though it says none), click the vertex normal map box

_____

weird

ernpchan
03-19-2015, 10:39 AM
Confirmed. Doing a F9 gets Layout to update properly.

jboudreau
03-19-2015, 12:07 PM
Thanks Guys, Just wanted to confirm that

Toggling the subpatch button, clicking the vertex normal map in the surface editor button and an F9 Render also fixes the problem.