PDA

View Full Version : Can't Package scene in 11.6.3 or 2015.2



2create
03-06-2015, 05:18 AM
Just wondering if anyone has come across this issue?

Try to package a scene to a new location and PCore Console shows:

Traceback (most recent call last):
File "C:\Program Files\NewTek\LightWave_2015.2\support\plugins\scri pts\Python\Layout\Generic\Package_Scene.py", line 518, in process
currenttruename = os.path.basename(currentfile)
File "C:\Program Files\NewTek\LightWave_2015.2\bin\python27.zip\ntp ath.py", line 170, in basename
File "C:\Program Files\NewTek\LightWave_2015.2\bin\python27.zip\ntp ath.py", line 142, in split
File "C:\Program Files\NewTek\LightWave_2015.2\bin\python27.zip\ntp ath.py", line 94, in splitdrive
TypeError: 'NoneType' object has no attribute '__getitem__'


With no files copied. Thanks for any feedback :)

souzou
03-06-2015, 06:13 AM
Hey Louis, just tried a package scene in 2015.2 to a different location (tried on same drive and a different drive) and didn't have any problems.
Was a small scene though (just a few objects).

2create
03-06-2015, 08:55 AM
Hey Louis, just tried a package scene in 2015.2 to a different location (tried on same drive and a different drive) and didn't have any problems.
Was a small scene though (just a few objects).

Thanks Matt, Just tried with another scene and worked also. Thinking there's some kind of corrupted element or something in the scene causing the error. It refused to render over the network too, weird :S

2create
03-06-2015, 10:00 AM
Sigh it was file permissions.

Somewhere along the lines some of the items in the project folder became read only.

Ma3rk
03-06-2015, 10:01 AM
FWIW, I've had issues with 11.6.2 where if I check the preserve existing structure option, objects wouldn't copy over but everything else would. Uncheck it and package again and it works as expected.