View Full Version : Rendering with LWSN version 2015.1

01-28-2015, 12:27 PM

I am been using LW 2015.1 intensively the last month and am planning to start a nice rant about it, but before I start I would like to ask if anyone is using LWSN with LW2015.1 without any issues.

I am used to setup Screamernet (beeing it with true Screamernet beeing with a renderfarm controller) since at least version 5.5, so I am no newbie with this. I setup Lightwave network render farms using from pure screamernet with *.bat files to Lightnet, Butterfly Netrender, Deadline, Smedge, RenderPal and something else I forget...

However, I can't setup LWSN version 2015.1 even if my life depends on it. Actually, my life depends on it and this project I am finishing is going much less smoother than it should for the sole reason I can't use a renderfarm. Eveerything works perfectly with LWSN version 11.6.3, as usual, but the same procedure applied with the new LWSN leads to weird rendered frames, with wrong camera settings, lights not beeing rendered, etc. There are no error messages, it can find the plugins and can find the objects etc, it just renders everything wrong.

Is anyone using LWSN (build 2833) with success?!

01-28-2015, 12:55 PM
I'm using Lightwave 2015.1's LWSN with BNR 5 and it seems to work fine here. At the studio where I was freelancing, LWSN worked with Deadline render but I had to modify one of the Deadline scripts--it had to do with an internal program name change, something like 'Lightwave 11' vs 'LW 2015'. I suspect other 3rd party render controllers may be affected by this change.

I haven't tried LWSN in standalone mode since 2015 came out but I'll check it out--sometimes I need to do that for testing purposes.


01-28-2015, 03:31 PM
Well, I don't get it. I built the config files in the same manner as usual, when running LWSN te output window doesn't complain about not finding plugins or objects so everything seems to be fine, I actually compared the output from 11.6.3 with 2015.1 and there is only one line different, something related with python which, I believe, should not matter.

In attach I am sending the LWSN logs and the render outputs. Frame 1 was rendered with LWSN2015.1 and Frame 3 was rendered with LWSN11.6.3

The scene is the old benchmark "Textures". As you can see, LWNS2015.1 has a different camera (I think the difference is the zoom factor), the lights don't seem to be working (we only see the objects which have reflection and/or Luminosity) and the background colours are messed up.

01-28-2015, 03:40 PM
I think setting the language of your operating system to English could fix the problem (something we're going to fix as soon as possible).

01-28-2015, 05:04 PM
My OS is already in English. Or are you talking about keyboard layouts?

Anyway, if you know there is an issue, specially in the render department which is the main reason for using Lightwave, and you don't fix it right away... man, I can't even find words for what I feel. After all, since I decided to make the stupidity of moving the project to version 2015.1 I had nothing but trouble, and this not-be-able-to-render situation was a big deal-breaker for me. I don't have a big renderfarm, just two computers, but one thing is to finish a scene, send it to the renderfarm queue and forget about it. Other thing is not being able to do that, having to render locally on one machine with several Layouts open while trying to keep working, not being even able to work on another machine, as I only have one LW licence, always worrying to not leave the machine unattended because something might go wrong, or could be idle when should be rendering and I have to always be on the lookout to see when did it render one scene so that it can start on the next one, etc, n short, this should go smoothly and as is my health is taking a big hit, becaseu of all the stress and all lost hours of sleep.

So no, I'm not happy...

01-28-2015, 11:40 PM
VirtualFM, I went through the same situation a couple of weeks ago, so I understand your bitterness. For me it wasn't a question of having the OS in English (I use a French version of Win7), but the decimal symbol defined in Regional and Language options. Please check if it is set to a point (and not a comma).

01-29-2015, 02:17 AM
Olivier, that's so crazy it might work! I will try it ASAP.

01-29-2015, 02:42 AM
I don't think Lino mean the language, I think he was talking about the regional settings, when you install windows you normally select language and regional settings at the same time.

It does sound like a possible reason, if some text file send float values as "0,5" for example and the parser expect "0.5", it will probably result in "0" (C/C++ would be 0), that could explain the black parts of the render.

01-29-2015, 08:27 AM
Hello! Just to report that it worked. Switching "." and "," made LWSN work again. Unfortunately not all is working 100%, Motion Blur is not doing well. I saved my scenes with Photoreal MotionBlur and it's rendering moblur in clear steps like if it was classic.

01-29-2015, 08:34 AM
Glad to hear you are back on track with ScreamerNet :)
As for the motion blur issue, I can't tell you since I didn't notice such issue on my side. Is it a ScreamerNet only issue ?

01-29-2015, 09:00 AM
Are you rendering instances?

01-30-2015, 07:00 PM
Of course, expecting users to alter their Regional Settings away from what is "normal" for their area just for Lightwave will create issues for properly-localized apps instead. Fixing one app by breaking multiple others is a poor "workaround", at best.

01-31-2015, 12:14 PM
Lino did say they are fixing this.