PDA

View Full Version : Surface changes brightness/luminance without anything activating it.



macahuna
01-23-2015, 12:35 PM
I've got a pretty simple animation going. One surface starts out at, say, 60% brightness until frame 79. At frame 80, it jumps to 40% brightness (getting brighter by 20%). I'd like the surface to remain at 40% throughout. There are no controls that I've set to cause the change. The lights don't have any changes throughout the animation, and the camera stays at the same level all the way. I've swapped out the texture for another texture, and everything works fine. The problem texture is an IFW2_ArtDeco node into a Surface node ( Color to color, Normal to normal) that's it.

According to the Scene Editor, there isn't a single object with a keyframe at that location. There are no gradients involved in that surface.

Is there a logical reason for the surface to change colors like that? I'm going nuts!

Thanks,

Ron

Sensei
01-23-2015, 01:37 PM
Make screen-shots and show us prior frame 80 and at frame 80..

Do you have specularity, reflections, refractions? What is glossiness?

Do you tried clamping color prior feeding color input in Node Editor?
Basically to not exceed 1,1,1 values.

Do you tried normalization of normal vector? Maybe it's buggy and is giving too high values (just guessing).

If you have GI, other surface can send light to your object/surface, and increase its brightness. So all info about whole scene is important, not just troublesome surface.

3DGFXStudios
01-23-2015, 01:47 PM
There is probably a logical reason but it is really hard to say what the problem could be without looking at your scene. Could you post it here?

JoePoe
01-23-2015, 02:14 PM
Look inside the IFW2 node.
Is there an envelope activated in there?

shadersrjj
01-24-2015, 12:37 AM
If you want me to take a look then contact me directly at [email protected]
I can then go through and find out what might be happening.
I'd like to get to the bottom of it in cause there's an IFW2 bug.