PDA

View Full Version : No Lens Flare in render



Philbert
12-21-2014, 12:19 AM
Can anyone think of why lens flares would appear in VPR but not in the F9 render? Thanks.

126201

jeric_synergy
12-21-2014, 12:28 AM
Is there a transparency the camera is looking thru?

Which camera are you using?

Philbert
12-21-2014, 12:29 AM
Real Lens Camera. Oh.. huh The light is inside this crystal in the staff which has transparency.

gerry_g
12-21-2014, 03:18 AM
Is lens flares on in the render globals panel

gerry_g
12-21-2014, 03:25 AM
works here

Kaptive
12-21-2014, 08:22 AM
Can anyone think of why lens flares would appear in VPR but not in the F9 render? Thanks.

126201

Are you sure it isn't working? I can see some faint traces of it in the render version. I think the thing is not to trust VPR and lens flares. It doesn't seem quite as accurate in my experience. Try turning it up really high and then render it to see if it is still hidden, but I'm pretty sure it's still there, just too low.

126206

gerry_g
12-21-2014, 08:43 AM
Sorry just had another look, turn off 'flare distance' in Flare options, that setting totally killed it for me, either I don't grasp it or it's broken, wrong it just totally disappears at 100% which seems back to front to me, see second post

gerry_g
12-21-2014, 08:52 AM
Ah , when I say turn on lens flare in render globals I mean not just the one on the LIGHTD tab but the one on the RENDER tab or it will not render, my bad

Philbert
12-21-2014, 11:11 AM
I'll take a look at some of these. For now I'll say that if I turn off the lens flare the VPR and F9 looks exactly the same.

http://content.screencast.com/users/philnolan3d/folders/Snagit/media/8dea2195-b17e-4239-b871-5ebac8569573/12.21.2014-13.10.png

Philbert
12-21-2014, 11:23 AM
works here

Looks like in yours you have Fade Behind Objects turned off. So it's just appearing on top of your model, not inside it.


Sorry just had another look, turn off 'flare distance' in Flare options, that setting totally killed it for me, either I don't grasp it or it's broken, wrong it just totally disappears at 100% which seems back to front to me, see second post

I don't see anything called "flare distance". The closest I see is "Flare dissolve" or "fade with distance".


Ah , when I say turn on lens flare in render globals I mean not just the one on the LIGHTD tab but the one on the RENDER tab or it will not render, my bad

Yes I do have it on in the Render tab as well as Light tab.

Maybe I just have to do my final render with VPR. lol

Kaptive
12-21-2014, 11:52 AM
Just spotted it, turn off Glow behind objects. That setting doesn't show up in VPR at all. In actual render you won't see the middle of the flare like you do in VPR.

126210

Philbert
12-21-2014, 12:04 PM
But I want it to look like VPR. The middle is the part I like. especially how it's behind the wood parts but slightly bleeding over them. I was actually just playing with Glow behind Objects and was about to post but didn't bother since it didn't really help anythign.

Edit: Oh wait, you're right. I misunderstood what you said but when I tried they now look very similar..

http://content.screencast.com/users/philnolan3d/folders/Snagit/media/89a80bb5-1be1-4875-88a4-034240c956c8/12.21.2014-14.07.png

Kaptive
12-21-2014, 12:06 PM
But I want it to look like VPR. The middle is the part I like. especially how it's behind the wood parts but slightly bleeding over them. I was actually just playing with Glow behind Objects and was about to post but didn't bother since it didn't really help anythign.

Here's an experiment. I cranked Flare intensity on the Render tab up to 500%

126212

See above post... Just turn Glow behind objects off. Should fix it.

Philbert
12-21-2014, 12:08 PM
Yeah it's just about right now, thanks!

Kaptive
12-21-2014, 12:12 PM
It was a new one on me too, I've never used that button before. Glad it worked :)