PDA

View Full Version : normal map problem?



amsvartnir
12-13-2014, 03:29 AM
hi all
first, sorry for my english.

I'm using Zbrush to generate some normal maps that sould look like old wood (but I've made only a few attempts); then I exported the maps to Lightwave, and with the node editor I've reached this result.

My problem is that the circled area is more blurred than the other one
thanks!

126037126038

stiff paper
12-13-2014, 07:06 AM
It's very hard to know anything from just the images.

Is that section smaller in the UV map? That would mean it uses fewer pixels, and therefore is lower resolution.

It's possible that it's just the lighting. With a normal map there are not any real shadows being cast, it's just affecting how much of any light it catches (so how bright or dark). When the surface is facing the light, then it will all be the same brightness, when the surface is at an angle to the light, it will have more dark areas and look like it has more detail.

This is just how normal maps work.

Or maybe it's something else (!)

Sensei
12-13-2014, 08:13 AM
Since you're beginner (at least to forum): did you set color-space correctly?

Normal map cannot be modified by color-space conversion routine.

Just asking.

Greenlaw
12-13-2014, 10:45 AM
What Sensei said. :)

If you are a beginner, here's some more info: if you're in sRGB color space, you must set your normal maps to Linear in the Image editor. (Regular color textures should be in sRGB of course.) Remember to save the object after making changes.

Also, try flipping the y axis. Normal maps from certain programs need this flipped, although I'm not sure if ZBrush is one of them. (I think GoZ is supposed to apply the correct setting for you.) This doesn't affect the blurring you mentioned but it does affect how the surface catches light.

As for the blurring, check that Mip Map is set to Off in the node. You usually want that off for normal maps.

If the texture res is too low, that might cause blurring too...although with Mip Map disabled, it will probably start aliasing if it's too low rather than blur. In this case, it's better to just use a higher res texture.

G.

Amurrell
12-16-2014, 08:48 PM
Change the colorspace here. My settings were correct in the colorspace section in display properties, but not for the normal map which should be adjusted here. Solved my problems.

126119