PDA

View Full Version : collision failure...please help a newbie



peji
11-29-2003, 09:03 PM
i'm currently doing an animation just for myself...

what it does is - there is an object (lamp) and just above it is an

HVemitter emitting particles downward ( -Y axis) somewhat

simulating a rain. i added a custom object to a part of my

object (lamp's head) with "FX Collision". now my problem is that

most of the particles emitted pass through the lamp's head as if

there was no collision but some particles colide with the lamp's

head.. does anybody know any walk-around for this problem?

thanx in advance

hrgiger
11-29-2003, 09:27 PM
Did you set your FXcollison type to object? You'll most likely have to play around with the radius setting as well.

peji
11-29-2003, 09:44 PM
yup...i already set it to object..if i set the radius to a higher value,

the particles will collide to something that's like an invicible

sphere and this still happens even if i set the radius to a lower

value like 1 and neglecting the object so i currently set the radius

to 0 to have the particles collide to the object and not to the

invicible sphere.. i think there's is something wrong with my

object..does "FX Collision" have any object requirements? like

polygon shape or something.. thanx for ur quick reply. i really

appreciate it:)

jsteen
11-30-2003, 08:23 AM
Try to raise your particle size a little bit. That will probably do the trick.

Jockomo
11-30-2003, 04:08 PM
First make sure your collision object has the polygons tripled. That can help sometimes.

If your particles are moving too fast, they can slip past the collision detection. Try reducing the -Y value you have set so they move very slowly. If this works then what you may need to do is render out all the frames then pull only frames you want for the animation. For example if you 1/2 the -y value, render out then pull every other frame.

peji
12-01-2003, 05:36 AM
i did ur advices and yeah they worked! but not entirely...i lose

some detail in the animation one way or the other...i did an

experiment-i created s simple flat poygon (rectangular in shape)

and just one polygon then i applied it to layout with the fx

collision and particle emitter and it worked perfectly! no particle

ever passed through the object and to think i used the default

values of the FX's..next, i subdivided the same object a couple of

times giving it more tiny polygons (i hope i described that well)

but mentaining the same rectangular shape but when i applied it

in layout w/ emitter and collision taht's the time the most of the

particles passed through the object..u get the picture right? so

what if i'm gonna do a very high poly object and apply collision

and emitter? this dilemma s giving me a headache... by the way,

thanx for ur replies:) i think i just found a new and very

intellectual community!:)

Jockomo
12-01-2003, 09:52 PM
Well your project sounds alot like issues I have just worked through myself.

First let me say that the particle system is Lightwave is pretty basic. Just like the sas plugin, it will allow you to do some basic stuff, and occasionally pull off something really nice. But when it comes to heavy duty calculations, PFX just doesn't cut it, well not in this century anyway.

My collision object has over 600,000 polys in it's simplest form.
The only way to get realistic looking fluids is to use ALOT of particles, currently I am looking at 16k particles. Now if you try to get lightwave to calculate that, your gonna be there forever.

This may be a little more extreme than your project, but for this, I finally decided I needed to move on to RealFlow(www.nextlimit.com (http://www.nextlimit.com) ). Granted I am having my fair share of issues with it as well, but they do not concern doing the particle calculation.

How many polys do you have in the new object?
Did you try slowing the particles down?
If your object has no thickness you may want to give it some, a thicker collision object may help.

jsteen
12-02-2003, 02:35 AM
Peji, the thing you describe with the heavy subdivided plane letting particles through is easily fixed.

Go into the option panel in the FX_Browser. The Resolution there defaults to 100mm. Lower it to 10mm or so, and then rerun the particle simulation with the start button in the FX_Browser, and it will probably catch all particles in the collision detection. If still some particles goes through, lower the resolution even more until everything is catched.

Hope this helps.

peji
12-04-2003, 10:32 AM
thanks 4 ur replies! very very informative...i finally got, well at

least i think i do ..hehhe.. i combined most of ur advices and voila!

coudln't have done it without ya! thankx again:)

HowardM
12-04-2003, 06:00 PM
well lets see it?!
:)

peji
12-05-2003, 09:59 AM
hehehe i ould love to show it 2 u but i just dont hav the patients

for this one... it will take gazillion years for it to be done

rendering but i'll be buying a new pc in a couple of days

so...hopefully by then i will be able to render it... thanx so much 4

ur interest- i really appreciate it:)