View Full Version : Spline Control Z value problem

11-29-2014, 05:07 PM

Hi Everybody,

I've got a problem where I'm trying to use spline control to control the movement of a snake model. I've got the snake rigged with bones, I've setup the spline according to the tutorial that Newtek put on YT...


I've done this a few times, and I'm pretty sure I've got the basics down.

As far as I can tell, I'm doing everything right, but when I try to move and/or rotate the Spline Control main node, which has all the other nodes parented to it, so I can position and orient the spline and make the model move where I want, I run into a strange issue that makes the spline control unusable. :confused:

This is hard to explain, but here goes.

When I change the value of Z in order to move the model along the spline in the timeline, sometimes, I enter in a value and the model moves in a distance and direction that makes no sense.

For example,

KF 0-200 Z=0
KF 300 Z= 915mm From here, the model moves along the spline in the direction I want. So far no problems.
KF 500 Z= 2m When I enter this value, the model suddenly jumps back in the wrong direction.

It's like when I enter in a Z distance from the point of origin, but it keeps changing which origin its using. As if its changing its point of reference from the origin of the first node in the spline to the Spline controller or maybe even the origin of the whole scene. I have no idea if that's what actually happening, but I can't think of anything else.

If I go back to the other key frames, some of the values they have are suddenly different as it they are also now referencing a different origin point.

When the Spline Control works, its great! But when **** like this comes up, its very very frustrating. :bangwall: Spine Control seems very straight forward, but its doing something that's totally counter intuitive.

Anybody have any ideas?

Thanks in advance,

11-29-2014, 07:30 PM
Your problem is probably related to the fact that for some reason Newtek used the objects z position for its distance along the spline but it allows the z position that is displayed in at the lower right of Layout's main window to be the world z position of the item. This mismatch means that if you enter numbers in the the z position field on the many window you can completely screw up the position of the object along the spline. To me this seem like surprisingly bad interface design. You should use the graph editor to change the value of the spline controlled item z position to avoid this wacky problem.

11-29-2014, 08:31 PM
Hey Lertola,

Thanks so much for your help. That seems to do the trick. It's very strange. You would think an error like that would show up elsewhere, such as when you parent objects to nulls or each other, but I've been using LW since V7.5 and have never had anything like this happen before. I think this is a bug vs a design error. The main fields in the lower left are obviously getting confused as to from where the Z value should be measured.

By the way, your avatar is absolutely disturbing! I LOVE IT! :D


11-30-2014, 01:53 AM
Nice catch Lertola, and indeed, insane decision on the UI input for spline control. IMO that control should be ghosted if Spline Control is engaged, ie it should be display only.

11-30-2014, 05:12 AM
All detailed here...


From 05:15 to about 9min

11-30-2014, 06:50 AM
Thanks for the Video Rebel!

I had seen that video in my searches, but when I saw the RH Rigging Tools in the title, I thought it was something else. Bad assumption on my part. Thanks again for all your help guys! :D

11-30-2014, 10:13 AM
Hey Guys,

I just went through the video and it was very informative, but one thing it said that seems to be wrong is they said its okay to use the arrows next to the value field for Z.


In the video, he used the Scrub Arrows to change the value and it worked fine for him, but when I tried it, the problem returned. The only way I can do it with out the issue it seems is to use the Graph Editor. Not sure why this is happening, but I thought I'd let everyone know.


11-30-2014, 04:20 PM
You can use the slider if you don't do anything that causes Lightwave to refresh the Z position value on the main window like changing the frame. This problem bit me once. The first job I used spline control on I had an animation of a snow boarder doing a jump with complex tumbling. I must have touched the z position control without realizing it because my animation became screwed up and I had no idea why. It took me a while before I found out what was going on. I would guess that a lot of Lightwave users initially have trouble with spline control because of this problem.

11-30-2014, 07:39 PM
It's like an exposed wire in a physical interface: the control should be ghosted to prevent users from screwing themselves over, and text in the status line saying "Use the GE".