PDA

View Full Version : Can I render only Depth pass?



idvaad
11-26-2014, 07:41 PM
Hi,

I have an issue, I rendered my scene with a depth pass ("compositing buffer export" in lightwave 11.5), but an object was excluded from the depth buffer... All my scene is rendered now.

Can I render only Depth pass? (for saving render time).

Thanks!

idvaad
11-26-2014, 08:41 PM
i cant find a solution like render only the depth pass...

But i did this: I configure the bufffer export to RGB image, and I turn the render to quickshade... I obtain the depth pass in less render time.

If someone knows about better solution, tell me please.

Thanks.

Shiny_Mike
11-26-2014, 08:57 PM
Probably not faster than quickshade, but an alternative is to select all of your objects - go to object properties /render tab -> click matte object (leave at default black) and setup a white fog for the "depth". Then untick raytrace shadows, reflections, radiosity, and remove any background environments.

jeric_synergy
11-26-2014, 10:08 PM
But i did this: I configure the bufffer export to RGB image, and I turn the render to quickshade... I obtain the depth pass in less render time.
If someone knows about better solution, tell me please.
Thanks.
Do we still have the WIREFRAME option? Hopefully, that would be even quicker than quickshade, assuming it's correctly evaluating the depth buffer.

Sensei
11-27-2014, 11:31 PM
If someone knows about better solution, tell me please.


See Global Materials (http://globalmaterials.trueart.eu) #4 video tutorial
https://www.youtube.com/watch?v=i5Ti9kZRGI8
I am setting up custom depth pass in a few seconds as one of passes.

It'll replace all objects, all surfaces, by nodal setup that will render extremely quickly just depth.