PDA

View Full Version : Aliasing does not go away, what am I doing wrong ?



madno
11-23-2014, 11:26 AM
Hi,

In the attached scene I can't get rid of the aliasing (most obvious at the edge of the geometry light). I tried with numerous combinations of settings, but it always looks like in the example render.

125642

And:

originally I wanted to try out LW's caustics. But there as well I could not get a reasonable result. Even with caustic quality set to 100000 and softness to 100 it did not look good (after 1 and a half hour rendering time). I would love to hear what I am doing wrong. The attached render is without caustics.

erikals
11-23-2014, 12:14 PM
you can't remove it completely in LightWave to my knowledge,

only way to do it is to render at 200% in lower AA quality, for then to scale down the render

sometimes activating "limit dynamic range" helps, but it does not remove it.

---------------

edit> in this case "limit dynamic range" helps quite a lot actually,
but remember LightWave AA is not the best, so rendering at 200% can be a good idea in similar scenes

lardbros
11-23-2014, 01:07 PM
Erikals is spot on... Turning on limit dynamic range will help hugely, try the setting on limit dynamic range to maximum of 2 instead if the default 1.0.

Also...if you're using adaptive sampling, and linear colour space, try putting your adaptive sampling on 0.001 to see if that clears it up a bit better?

Dan Ritchie
11-23-2014, 01:17 PM
Intense lights will always alias. Think of it this way. Anti aliasing is done by averaging nearby samples. if a nearby sample is on a light, and that light has a high value, say 10,000, while other nearby pixels mostely fall in the 0-255 range, that's going to throw off the average qite a lot, causing aliasing.

The solution is to use a less intense light, or to clamp high dynamic range, or to use a bloom effect that spreads out the error over a larger space.

lardbros
11-23-2014, 01:27 PM
Yep! :) Better than my explanation.

Also, it's not anything that's purely a LightWave issue, I get the same thing using Mental Ray in 3ds Max.

I got so carried away answering your question about aliasing issues, that I never saw the caustics bit.

Caustics is hugely reliant on different factors... The light type, the materials... Ummm, there are probably more, but can't think right now.
It's also old, hasn't been updated for years, and I've never managed to get brilliant results from it. But saying that, I know many people have, and it can look great!

I tend to go for a brute force method, using GI, non-interpolated, with adaptive sampling set with many samples and GI rays set really low, like 4, and make sure that directional rays is turned on too. Sometimes this can yield good results.

erikals
11-23-2014, 01:57 PM
for Caustics, also see my video >
https://www.youtube.com/watch?v=Tdea_CFAZ8E

Greenlaw
11-23-2014, 02:00 PM
As noted above, super high-contrast areas can be problematic for AA.

Try adjusting your lighting to minimize this. If you're using extreme light settings, it can push values way beyond normal. (Just as negative lights can push your values way below normal, which can produce weird results in compositing.)

Another thing to try is to set your Oversample to 0.25 or 0.30. This setting is essentially what was hardwired into the old Classic Camera, and it results in slightly softer edges around geometry and in alpha channels. IMO, it's nicer to comp with and it helps reduce the razor sharp crispness that usually betrays cg.

Hope this helps.

G.

erikals
11-23-2014, 02:05 PM
nice info here, thanks all... http://erikalstad.com/backup/misc.php_files/smile.gif

gerardstrada
11-24-2014, 01:25 PM
Limiting dynamic range will indeed help. A way to preserve dynamic range by getting limited DR AA is by using DP FNE:


http://s27.postimg.org/w8d07dbcj/AAtest.gif

Just limit the dynamic range at render time in DP Pixel Filter Node Editor and use DP Global Buffer for storing the non-limited (full HDR) version of the render:


http://s12.postimg.org/598evnmvh/DPPFNEaa.png

Save both renders (the LDR one and the HDR version) with DP Get Global Buffers (use some floating point format as EXR).

Later in post-processing (your compositing package or DP Image Filter Node editor), isolate the antialiased areas by subtracting the LDR version from the limited HDR version. After sub-expose/tonemap the highlights at convenience, replace the aliased areas with the AA areas by subtracting them from the post-processed version. A simple setup could be something like this:


http://s11.postimg.org/abyvtv3er/DPIFNEaa.png

Additionally, you might want to weight the good AA areas with the tonemapped version by using a scale node before subtracting. More info about this technique (and a more advanced setup and shared files) in this thread:

http://forums.newtek.com/showthread.php?119485-Why-is-the-quot-Adaptive-Sampling-quot-pass-so-slow&p=1144858&viewfull=1#post1144858



Gerardo

p.d. attaching a sample with your scene.

madno
11-24-2014, 02:58 PM
Guys you are amazing,
I will try out. Tested "limit dynamic range" with some success. It helped but did not eliminate aliasing completely like Ericalsa and lardbros predicted; same with oversample to 0.3. Anyway scene is just a hack for fun (I don't like the room/floor at all, need to make something better). Not yet tried with HDR instead of light and luminous geometry. And sorry for not switching off the preprocesses in the Schlick's node. It was one test I made and forgot to swtich it off before posting the zip. Tried bloom which locked awul. Need to play with settings. And then the advanced (for me) DP node stuff.
Read so many threads about good, better, bad, worse packages but most of the time it is really about knowing the tool instead of judging it.

madno
11-24-2014, 05:19 PM
DP to the rescue,

still not perfect but much better. Thanks all.

125674

(by the way - rendered with the LW 2015 trial)