PDA

View Full Version : LWCAD Curve to Polygon Issue



jboudreau
11-14-2014, 03:03 PM
Hi Guys

I'm using LWCAD 4.5.1 under Lightwave 11.6.3

When I have two or more LWCAD primitive curves in separate layers, and go to convert from curve to polygon under layer one without any of the other layers selected all my layers curves convert.


Steps to recreate this problem

Create a LWCAD primitive (Curve) Rectangle in the first layer
Create a LWCAD primitive (Curve) Circle in the second layer
Select the first layer only
Press the LWCAD Curve to Poly button

Both layers convert instead of just the first layer. Shouldn't just the active layer convert? If so what do you think could be the problem here

UPDATE:

It seems to happen because the Curve to Poly button stays activated and any action I do Copy, click on another layer etc it keeps converting from curves to polygons

Steps to recreate this problem

Create a LWCAD primitive (Curve) Rectangle in the first layer
Create a LWCAD primitive (Curve) Circle in the second layer
Create a LWCAD primitive (Curve) Circle in the third layer
Create a LWCAD primitive (Curve) Circle in the fourth layer
Select the first layer only
Press the LWCAD Curve to Poly button
Click on the second layer
Click on the third layer
Click on the fourth layer

Each layer will be converted from curves to polygons

the only way to stop this is after you press LWCAD Curve to poly button you have to hit the spacebar to deactivate the tool.

Thanks,
Jason

Snosrap
11-14-2014, 08:43 PM
Yep thats how it works and yes a lot of the tools remain live until you drop them.