PDA

View Full Version : Issues with DEPTH Buffer



khan973
11-05-2014, 06:13 AM
Hi, I constantly run into an issue and it's very annoying.
I'm trying to export DEPTH pass (I'm on 11.6.3 but previous ones did the same)
I go to Compositing Buffer export inder Image Filter.
I choose Image File, the Format (.exr), I check Save on F9 & F10 Renders
I check Depth on the Buffer Tab and I use Limit Buffer Depth under Depth Option to set a limit (without limit it's the same).
I verify that All desired objects are active under Objects Tab.
So if I render in Image Viewer, it's fine, but if I leave to Image Files so it's saved on a disk, most of the time or randomly on some projects, all the images are all white.
It's really annoying because I often have to do the Fog trick to get my Depth...
It's been like that for ages. On the last project, no problem. On the previous one, same problem and there is nothing I do differently.
Does somebody know what's going on?


ps: I check by changing the exposure of the rendered image and it's 100% plain white.
I tried many different formats too.

Sometimes to overcome the issue, I have to start with a scene where it works, empty it, import all my objects and settings. Clearly not a reliable workflow...

Lewis
11-05-2014, 06:44 AM
It's all white in Composition program or really white (loaded back in LW and opened in Image editor = still white)?

what do you use for compositing (AE?)?

Red_Oddity
11-05-2014, 07:14 AM
Are you saving to a float format? If not, did you normalize your depth buffer data? If not, then it's logical your image contains nothing but 'white' pixels.

Every4thPixel
11-05-2014, 08:02 AM
I'd like to add.. Limiting your depth buffer doesn't normalize it. You probably see a full white image because all values are above 1. Normalizing the depth buffer can cause jumps in your depth map so that isn't always reliable. I would recommend you to use the full white image (which does have depth data in it if you save a float format)

khan973
11-05-2014, 01:05 PM
The Problem is that I open it in compositing program and it's all white, I changed the exposure just to be sure a dit's plain white.
Limiting my depth Buffer shortens the range from 0 (camera) to whatever value I chose which is what I'm after.
No I didn't normalized it as I don't want the sharp lines between grey values and this doesn't allow the full potential of depth that we get by saving in full floating format like .exr or .hdr.
I've been using the fog trick for years but now I want to be able to use the Buffer Export again and it's frustrating.
I tried one day to import (Load Item from Scene) the Bufffer Export of a scene where it worked and by importing it in Image Filter, magically, it works on the scene with the exact same parameters. It really looks like a bug to me

- - - Updated - - -

Especially because everything is fine when I just want to have it in the Image viewer and not saved on a disk.

blindsided
06-30-2017, 10:31 AM
I have been playing about with this lately and found it a struggle. I have however, had a lightbulb moment which has helped, hopefully it may be the same for you?
Export the Depth pass via the compositing buffer export as EXR.
import into After Effects. Create a composition with the file. Apply the EXtractoR effect. In the effect settings click one of the channel infos (RGBA) in the pop up window change the top tab from Layers to Z.
That should give u a decent depth image. apply the INVERT effect and drag the composition into a composition with your rendered image and appy as a depth pass, and hopefully that should work?
jm

Danner
06-30-2017, 02:26 PM
If you install this plugin into photoshop you can see if all your layers are ok on the EXR. The depth pass is visible as a grayscale, but the exposure has to be adjusted if you want to see the surface ID layer.
http://www.exr-io.com/