View Full Version : Object Sequence- Does not work?

11-28-2003, 09:59 AM
I can't seem to get the object sequencer to work at all.
Is there a plugin I need to load or something? (edit: I found the objrep.p plugin and reloaded it. It said 3 plugs loaded. but still no success)

Here is what is happening:
I have a list of objects (have tried with different sets of objects)
they are numbered box000.lwo, box001.lwo, box002.lwo, etc.
I load the first one up (box000.lwo) then go to Object Properties>Geometry>Object Replacement and select Object Sequencer. It does not show up as active, it just resets back to [none].

Can anyone get this to work??

11-28-2003, 10:14 AM
I get the same thing as you, you might have to use ObjList.

11-28-2003, 10:46 AM
Thanks for checking it out Wiz, I wish the solution to my problem was as simple as that even though I have a thousand frames to deal with.

Beyond the Object Replacement plugin issue, I am trying to get RealFlow to work, and it seems Object Replacement is used by that program in conjunction with it's own plugin.

Guess I'll email NewTek and see what they can do.

12-01-2003, 02:11 AM
It does work, but doesn't show it's working. If you put it on, it will show (none) still, but make a preview of your scene and you will see that the objects do get replaced.


12-01-2003, 11:12 AM

Thanks for your reply! I also got a reply from NewTek Support today with the same answer.

12-08-2003, 01:25 PM
Also the problem is that LW does not update the object as you scrub across the timeline. This is a real short-coming when dealing with objects that get replaced on a frame by frame basis such as those generated by Realflow.

While it is true that doing a preview will prove that the objects are getting replaced, I have found that once previewed the sequence does not reset back to the object at frame 0. The last object previewed gets stuck as the default object. If there is a work-around to reset back to object001 each time please let me know.

There is a script for this IL_scrubreplace but I have been unable to get it to work with 7.5

It worked with 6.5 and I have replaced it with the 7.5 version but still no go.

Anyone else using this script with success in 7.5?

12-08-2003, 01:59 PM
i thynk the object not getting reset to 0 is also an ogl/pannel
update issue. If you do a frame render it should revert to the object associated with the frame you render.

as an aside, the version that shipped with Lightwave 7 (ObjRep.P) seems to work slightly better - or i should say atleast it sorta updates the Object Properties pannel - it just doesnt list the path (which is usually to damned long to see in that small dropdown
box anyways...)

- Will.