PDA

View Full Version : Maintaining object position during dynamic parenting



MikeHaggar
10-18-2014, 06:58 PM
Hello,

I'm very much a beginner with LightWave (v11.6) and am hoping someone with more experience can help me out. I've been tasked with animating a vehicle along a path, following a list of positions indicating where the vehicle should be at certain frames. If you imagine an upside down "T" shape on the XZ plane, the object begins at the bottom right vertex of the "T", drives to the top vertex, reverses to the bottom left vertex, then drives forward again to the original position. Of course, it's not supposed to make sharp 90 turns, so the plan is to parent the object to a null then rotate the null to produce a smooth turn around the corners (the object essentially orbits around the null when cornering).

The first turn is to the right (if we imagine we're in the drivers seat), so obviously the null is offset to the right of the vehicle. This seems to suggest that when I reach the frame where the vehicle comes to rest before beginning to reverse, I need to hand control over to a second null that's offset to the left of the vehicle. After a bit of reading I found the Dynamic Parenting modifier in the Motion Options for the vehicle object, and use that to change the parenting of the vehicle to the second null. The second null then moves the vehicle backwards and rotates it around the second turn.

This seems to work fine for the most part, but the vehicle offsets a little during the parenting transition, so the overall animation does not look smooth. In the Edit Parent Relationship window, I have checked Keep Initial Position and Keep Initial Rotation (or rather, left them checked as that is the default setting), but the vehicle still changes its position slightly and I can't figure out why. After hours of frustration I started again with a clean slate, and noticed this time that even before I've done anything beyond frame 0 (ie nothing is moving), the moment I parent the vehicle to the first null using Dynamic Parenting it offsets the vehicle, seemingly by the same amount that it was doing it last time. This offset appears to be consistent, regardless of where the null is placed relative to the object. I've also noticed that this doesn't occur if I directly parent the vehicle to the null in the Motion Options, but that is no help as I need to use multiple nulls.

So, can anyone shed some light on the cause of this offset? Is using two nulls like this the right way to approach the problem? I would have thought the only difference between standard parenting and the Dynamic Parenting modifier would be, well, the ability to dynamically change the parent! Any suggestions would be greatly appreciated, this is incredibly frustrating.

RebelHill
10-19-2014, 04:22 AM
Yeah... the parenter pugin has long suffered this in certain situations... it just "bumps" things.

Try using constraints instead... https://www.youtube.com/watch?v=U6OL7oBg-ug

jeric_synergy
10-19-2014, 09:35 AM
Wow, talk about "burying the lede": that LAYERED (or sequential dynamic parenting) is INCREDIBLY powerful!!!

MikeHaggar
10-20-2014, 01:04 AM
Yeah, sorry about that. I thought it best to err on the side of providing too many details rather than not enough, I'm still a new user so I wouldn't have been surprised if I'd been told I was going about the problem in entirely the wrong way!

Thanks for the suggestion RebelHill. I ended up getting the results I wanted by manually correcting the offset, which meant having to plan everything out on paper first as none of my co-ordinates matched up with the instructions. That was fine for something this simple but constraints look like the way to go for more complex projects. I also learnt a lot about Cyclist and Relativity along the way, so it was a good exercise overall.

It's a shame the Dynamic Parenting seems a little undercooked, it'd be nice to have a Graph Editor style interface.