PDA

View Full Version : ZBrush and Lightwave - normal and displacment maps



Reis
10-15-2014, 04:12 AM
Hi Guys,

I can't seem to figure out how to link the maps up correctly in lightwave, here is what I've done..

I have the normal and displacement maps, both match the shape of the UV's so i know thats not the issue.
I've selected my object in layout and increased the subdivisions to 5 as that matched the subdivisions in ZBrush.
I've enabled bump in the object render settings
I've made sure all the maps link to the same UV Map
I've tried connecting the normal map through the node based editor with 'Normal Map node'
I've tried to add the displacement map through the object rende settings, and assigned the UV Map to it, however I still have XYZ at the top or my displacement map node window?

And I just don't see what I see in Zbrush, in fact I see no changes. I just wanted to see how I can get them to work as its frustrating. Thank you for any help or advice in advance.

R.

MarcusM
10-15-2014, 04:37 AM
In "LightWave_11_Pre_Content" is "Luis_Santos_Mutant_NewTek". There you can check everything.

Surrealist.
10-15-2014, 04:44 AM
Seems like there is a lot of missing information here. The displacement map - the grey scale one - can be applied a couple of ways. If you enable bump in the object properties this means it will take the bump map channel in the Surface Editor and apply that as a displacement. This would be the grey scale map not the normal map. And you'd set that up first.

The Displacement Map option with the T next to it to set up the texture is only for XYZ. And by default the distance is set to 0. So you'd have to adjust that to see anything.

Another way is to add "Normal Displacement" in the deform panel (not to be confused with a normal map). This is displacement along the normals using a displacement map. You then use the Texture button to set up a texture after you open up the properties of that displacement modifier. By default the distance is set to 1 (meter if that is how your preferences are set).

Normal maps are used only for fine detail and are set up differently than Displacement Maps. You'll only see that with VPR or render AFIAK.

bazsa73
10-15-2014, 05:04 AM
Make sure that Mipmap mode in the Image Editor/ Source tab is set to SOFTNESS.

Reis
10-15-2014, 05:31 AM
Thank you for your input makes things a little clearer.
I just don't seem able to transfer my detail from my ZBrush model into my lightwave model and get the same results.

I tried what you said Surrealist about putting my displacement map into the bump, then on the object properties > Deform I enabled bump and adjusted the distance, but it looks like it just balloons the object and doesn't look at the map or anything like the shape in ZBrush.

And I just tried the Mipmap to softness and that didn't effect it either.
See the attached, thats the normal model. The ZBrush one has creases that are slightly more defined and a couple more crinkles/ bumps.

Thanks for your help by the way.
125002

bazsa73
10-15-2014, 05:52 AM
-Did you flip the displacement alpha in ZB or used GoZ? If you export manually the map from ZB then you have to flip the map in zbrush under the alpha menu.

I have a node setup here. Try this for node setup
125003

But dont forfet to replace the UV map name. And increase the subdiv level, sometimes it helps.

Surrealist.
10-15-2014, 05:54 AM
I'd have to see more settings. But when you say it balloons the object it leads me to believe that the image is not being applied properly. But I'd have to see the surface editor settings.

You can also just try the Normal Displacement. That also requires and proper surface editor set up.

Do get the help you want, I think you are going to have to post more screen caps of settings of all panels and get more specific about your set up.

hrgiger
10-15-2014, 06:08 AM
If you just Use GoZ, sending it to Layout will set up your maps for you in the node editor if you've already created them.

Reis
10-15-2014, 07:31 AM
If you just Use GoZ, sending it to Layout will set up your maps for you in the node editor if you've already created them.

Did this and it works. Looking at all the settings, some maps are inverted in certain axis. Thanks for the help

bazsa73
10-15-2014, 07:48 AM
Did this and it works. Looking at all the settings, some maps are inverted in certain axis. Thanks for the help

I forgot to say it's the Vertical FLip button in the Alpha menu in Zbrush. First menu item top row.

gerry_g
10-15-2014, 08:55 AM
mip map is about camera distance to object it's meant to cancel out textures at a distance to the camera to save on unwanted noise/render time, meaning if your object is over size and you camera is an unrealistic distance away all bump ends up getting canceled, OFF is the best setting I find.

Surrealist.
10-15-2014, 10:40 AM
Did this and it works. Looking at all the settings, some maps are inverted in certain axis. Thanks for the help

Yeah the flipped map issue as mentioned. But my advice is not to let this be a crutch. Learn from it and know how to set these maps up manually. It is a basic skill you need in LW or any other app for that matter. :)