PDA

View Full Version : LW Render shows gaps between polys



DelendaMaximus
09-29-2014, 04:59 PM
Hi, I have a section of a rocket body that has no 1 or 2 point polys, yet the rendered image shows these gaps. 124565 Any ideas on how to get the polys joined at the edges?

Thanks
Bill

- - - Updated - - -

Another better image:
124566

Sensei
09-29-2014, 05:11 PM
It's possible for triangles, quads, and other polygons to share the same point, so they will look like 2-point polygon.
Press m to merge points,
then Unify Polygons shift-i.
After that check whether Polygons Statistics is showing or not 1-2 point polygons.

Change color of background to check whether color of gaps will also change color..

DelendaMaximus
09-29-2014, 05:31 PM
Tried the Merge and it found 2 points... Unify found nothing.

Thanks for the tips though...

Image with black background attached
124567

Sensei
09-29-2014, 05:38 PM
Maybe these gaps are real?

Try zooming in, and using lasso, and check on bottom-left quantity of selected points (or Point Info i key)..

Alternatively use Merge Points with higher distance (Fixed mode).

JoePoe
09-29-2014, 05:41 PM
Interesting object. I can't for seem to figure how it was made..... unless you did a lot of band gluing.
Man, that's a lot of polys for the main ring :). Whata' u got there 1000 for the full loop?

Anyway, see my pic below for notes. I think the gaps are real. Like Sensei says.

Edit: And if you want a quick, to the point, assessment of the issue..... post the .lwo ;)

124568

Dodgy
09-29-2014, 05:53 PM
The problem is caused by very close points on n-gons. IE they're almost quads, but have another point close to a corner. They don't show up in VPR because VPR traingulates all polys before rendering. Try tripling all n-gons and then rendering. I tend to get these problems on CAD converted meshes.

DelendaMaximus
09-29-2014, 05:58 PM
Model history - mfr sent CAD model and I translated it but that was reaally big, so I just remade the thing from scratch.

Model attached:
124569

prometheus
09-29-2014, 06:10 PM
thereīs some gaps in there, as with cad models, best is to find out from where it is exported, and in which format...and track that down..and make sure to export it and weld the vertexes first.
In lightwave you need to weld/or merge the points to avoid the gaps..and can be tedious if you have a lot of polys or a complex mesh.

also..make your surface isdouble sided so we can see both sides :)

as sensei mentioned, you can merge/weld the points if you click on fixed, where you can set a distance ..so every point within that distance will merge, but it could also merge point you donīt want to merge..so the best is to make sure it is welded in the original program before exporting.

I tested 2-3 mm merging with the fixed option, but not much is happening..two points merged perhaps, changed to 10mm and it reduced over 2000 points...and some gaps..if not almost all were closed, you have to
be careful not to set it to high so it destroy the geometry otherwise.

havent checked it properly, but there is still a gap, but that must be closed manually, by selecting surrounding points and make poly...hit "p"

JoePoe
09-29-2014, 06:12 PM
U do have 1200 2 point polys. But I don't think that's the problem. They are on the outside edge. Get rid of them anyway.
I think the winner here is Dodgy. Triple non-planars (which are your ngons in this case.)

BUT.... all those triangles coming together may cause a smoothing issue. I got some "ripples" with no smoothing. It's a bit better with a small-ish amount. 30 seems okay.
Guess it depends on how close u want to get.... and your personal threshold for such things. :)

DelendaMaximus
09-29-2014, 06:15 PM
Yay!

Tripling the n-gons did the trick! Nice smooth surface and NO gaps!

Thank you all!

Attached image:
124570

prometheus
09-29-2014, 06:23 PM
A tip...for best viewing of the area, select point or nearby polys...use shift-a as a shortcut command, that will fit the selected poly or points in the viewport.

prometheus
09-29-2014, 06:26 PM
Why do you have to use that dense mesh as a subpatch? i simply merged the points and closed the gap of the single gap, and it renders fine without switching to subpatch.
Ehh..sorry, mistaken you have to make it subpatch...but anyway, tripling the geometry donīt solve the issue, and your image do not have a smooth surface, are you sure it really is closed?

prometheus
09-29-2014, 06:41 PM
looks good with only merging the points and closing the gap that was left over, reduced points and no additional triple of the geometry, smoothing angle at 9%

minor surface artifacts perhaps do to ngons, at the edge of the rim, might work to triple it, not sure..maybe instead use merge trigons? a free plugin.

http://forums.newtek.com/attachment.php?attachmentid=124571&d=1412037654

124571

prometheus
09-29-2014, 07:10 PM
U do have 1200 2 point polys. But I don't think that's the problem. They are on the outside edge. Get rid of them anyway.
I think the winner here is Dodgy. Triple non-planars (which are your ngons in this case.)

BUT.... all those triangles coming together may cause a smoothing issue. I got some "ripples" with no smoothing. It's a bit better with a small-ish amount. 30 seems okay.
Guess it depends on how close u want to get.... and your personal threshold for such things. :)

yeah..I ran merge trigons and it does a good job on some parts..the whole front surface becomes quads, and some side surface is cleaned up, so at the edge it actually looks better than the image I posted above, and it has a sharp edge without pinching..but merge trigons also screwed up some areas, best thing is to model it all again in lightwave :) or forward a request of a quad tesselation engine ala modo cad loaders.

I used go the route of solidworks to deep exploration and set a perfect smoothing angle in there, and it exported with vertex normal maps, and once I got the hang of it, it was a better option than trying every smoothing angle possible in the surface editor.

DelendaMaximus
09-29-2014, 09:08 PM
@Prometheus- Great tips thank you! The original model came from Solidworks, ran it through PolyTrans but it was gigantic in size, so I just copied the "bumps" and made a cylinder and Boolean Added them together, cleaned up the mesh and that's where the gaps come in.

Thanks again,
Bill Bolton
Altius Space Machines
Louisville, CO

prometheus
09-29-2014, 09:16 PM
these are useful for cleaning up and also closing ngon polyīs..all free plugins...
https://www.lightwave3d.com/assets/plugins/entry/mergetrigonsx/
https://www.lightwave3d.com/assets/plugins/entry/cm_polydivide/
https://www.lightwave3d.com/assets/plugins/entry/polysew/

all free, thereīs also multiply/subdivide/more/fast triple fan reverse to triple poly selections.

Itīs no rocket sience...or maybe it is? :)