PDA

View Full Version : OBJ Export doesn't export smoothing INFO.. Why?



chippwalters
09-24-2014, 05:38 PM
I have a .lwo file (1) which when I export to .obj for rendering in Keyshot doesn't seem to export the smoothing normals correctly. It comes in as a facetted model in Keyshot. I thought maybe Keyshot was the problem, but then I tried importing the .obj into Modeler and I got the same problem (2). Has anyone seen this before? Is there a workaround or is this a known bug? TIA for any advice.

The .lwo model: http://dl.dropboxusercontent.com/u/3788438/DontMove/TestSmooth.lwo
The .obj model: http://dl.dropboxusercontent.com/u/3788438/DontMove/TestSmooth.obj
The mtl file: : http://dl.dropboxusercontent.com/u/3788438/DontMove/TestSmooth.mtl

http://dl.dropboxusercontent.com/u/3788438/DontMove/TestSmooth.png

JoePoe
09-24-2014, 06:03 PM
Set Vertex Normal map to None in Surface editor. Re-save. (and have smoothing on, of course :))
That will do it in LW. Don't have Keyshot to test.

Edit: I believe there's a check box to include/exclude vmaps on export in preferences. Away from LW right now so I can't be exact. Pretty sure it's there somewhere. ;) ...Ahhhh, it's on the tip of my mind.... uncheck "Write Normals"... I think.

chippwalters
09-24-2014, 06:46 PM
I think I figured it out. There is a flat display object in the middle of the model with smoothing turned off (it's just a plane which has a display image mapped on it). Turns out when you freeze a smoothed textured object simultaneously with a non-smoothed textured object, it changes the normals for the whole model in a way which DOES NOT display in Modeler at the time. For some reason Lightwave continues to *understand* the smoothing definition, but exports it all with the non-smoothed setting. So, the solution is to freeze sub-d models separately if any of them are differently smoothed.

- - - Updated - - -


Set Vertex Normal map to None in Surface editor. Re-save. (and have smoothing on, of course :))
That will do it in LW. Don't have Keyshot to test.

Edit: I believe there's a check box to include/exclude vmaps on export in preferences. Away from LW right now so I can't be exact. Pretty sure it's there somewhere. ;) ...Ahhhh, it's on the tip of my mind.... uncheck "Write Normals"... I think.

Thanks for the advice. I'll try that as well.

madno
09-26-2014, 11:35 AM
I tried your file;
obj export / import seems to have its own mind;
but regarding smoothing at least: uncheck "write normals"
like JoePoe said did the trick in my LW test (don't have keyshot).

124503

chippwalters
09-26-2014, 01:40 PM
Great advice. Thanks! I tried it and it worked for Keyshot too. :-)