View Full Version : Naming: bee in bonnet: "Clone Instance" versue "Instance Clone"

09-16-2014, 09:36 AM
So, putting this here because proper, helpful NAMES are the first line of good 'documentation', or UI (see tag).

Obviously, this is SO low priority I should go have a cup of tea instead, BUT: ;)

The function name "CLONE INSTANCE" seems very opaque to me, while "INSTANCE CLONE" seems much more in the spirit of what the function does.

YMMV, and
we all have the power to rename the button, and
it's not like it's a time-hallowed LW tradition,

so it would please me INORDINATELY if LW3dG changed the name of that thing officially.

I'd even settle :D for "CLONE: INSTANCE".

It just bugs me.

09-19-2014, 06:36 AM
Sorry... I'm not sure if I agree, but hey... so long as it had Clone in it somewhere, I'd probably be okay with it. :)

09-19-2014, 09:05 AM
"Clone VIA Instance"

To me, the INSTANCE part is more important than the CLONE part. Hence, "Instance Clone".

"Single Instance"

All my cloners have their own division, so in my UI it's obvious that cloning is what's going to happen...

09-25-2014, 06:19 AM
Think I'm the opposite... sorry! :D

I see the Cloning as the important part, then Instance as the descriptor.

Wonder what others think?

09-25-2014, 10:49 AM
I suspect my difficulties with this is that Layout 'clone' never really was what I'd call a REAL clone, it was always just duplication, or really just copying. ---since 'clones' don't dynamically interact.

##squirrel!!## We can't Instance Lights, right?

09-26-2014, 05:17 PM
Clone as Instance?

09-26-2014, 05:56 PM
That'd work, but I think the button is too small. ;)

One way around is to make a menu division, CLONING, and assume the buttons refer to the division label.