PDA

View Full Version : Saving Scenes with certain visibility settings causes your objects to go black!



jboudreau
09-03-2014, 01:50 AM
Hi Guys

I came across what I think is a bug. If you save your scene with your objects set to any of the four visibility setting in the dope editor (hidden, Bounding Box, Vertices or wireframe) when you load back in your scene and go to change the visibility back to (shaded solid, Textured Solid or Textured w/Wireframe) The object goes black in the openGL viewport but renders out fine with both VPR and F9 Render. I figured out the bug is caused by the studio live button.

Steps to check if this is a bug.

- Make sure the studio live button is not active (Not lit up blue)
- Create a ball in modeler
- Send it over to layout
- Clone the ball 3 times and move them so you can see 3 balls in your viewport
- Go into the dope editor and change each ball to one of these visibility settings (hidden, Bounding Box, Vertices or wireframe)
- Save the scene
- Re-Open the scene and change the balls to one of these visibility settings (shaded solid, Textured Solid or Textured w/Wireframe)

All the balls should go black with no surfaces on them.

If you go back into the dope editor and change all the objects back to one of these visibility settings (shaded solid, Textured Solid or Textured w/Wireframe)

Then save the scene and re-open it all the objects should be back to normal.

FIX / WORKAROUND

If you have any objects in your scene that are using any of these visibility settings (hidden, Bounding Box, Vertices or wireframe)

Make sure the Studio Live Button is activated before saving the scene.

Now when you re-open the scene everything should work as normal no more black objects and no need to change the visibility settings of all your objects and re-open the scene again.


Please let me know if anyone else is getting this bug on their system. I'm using lightwave 11.6.3. If so I will fogBug it to newtek

Thanks,
Jason

Every4thPixel
09-03-2014, 02:06 AM
This happened to me as well. The problem disappeared when I updated my Nvidia driver.

jboudreau
09-03-2014, 08:57 AM
This happened to me as well. The problem disappeared when I updated my Nvidia driver.

Hi

I tried updating my Nvidia Driver to the latest version and it still does it. Does anyone else have this issue?

Thanks,
Jason