PDA

View Full Version : Points refuse to merge?



objuan
08-20-2014, 03:20 PM
I've been having an inconsistent issue where points refuse to merge together when I press m.

Often it works fine, but sometimes it wont do anything. m - Automatic doesnt work, m - Fixed doesnt work either. I checked and each set of 2 points are in the exact same location. WTF?

In this case the objects were created with the clone tool and a vertical offset, but I think I've had issues under other circumstances.

Any ideas?

ernpchan
08-20-2014, 03:33 PM
Do you have a morph on your object?

objuan
08-20-2014, 03:36 PM
I think I might have some residual morphage from whence I copied the source.

Is that the culprit? How do I get ride of that? There are actually like 6 different morph groups.

ernpchan
08-20-2014, 03:38 PM
Yes...you can't merge points if you have a morph on your object.

You'll have to delete all your morphs to do this destructive type of editing.

objuan
08-20-2014, 04:20 PM
Thanks, but how do I delete all my maps?

I can select each morph, and hit Clear Map, which sets all the points to their base position, but it doesnt seem to get rid of the map. I tryed doing this for all my morphs, and copying the polys into a new object, and the blank maps are still there.

Die map, DIE!!!

RebelHill
08-20-2014, 04:30 PM
right click the maps in vertex maps panel and choose delete.

And while you cant merge, you can weld points with maps present

ernpchan
08-20-2014, 04:30 PM
You could see if this script helps.
http://forums.newtek.com/showthread.php?133426-Bulk-Delete-VMaps&p=1299720#post1299720

objuan
08-20-2014, 05:10 PM
There's a Vertex Maps Panel eh? Hot damn!

Thanks guys.

MarcusM
08-20-2014, 05:25 PM
There's a Vertex Maps Panel eh? Hot damn!

Thanks guys.

:D

Maybe you trying merge points from two layers? ;]

objuan
08-20-2014, 06:10 PM
Huh? Well, I deleted all the Morph maps in the Vertex Maps Panel - cant merge.
I installed the Bulk Delete VMap.ls, it shows some maps that dont show up in the Vertex panel (I think they were maps on other layers of the original object, but not on these points) I tired to Bulk Delete VMap.ls which didnt seem to do anything. Except, it would briefly flash the top most map in its panel, in the vertex panel, which if I could manage to catch with a right click, I could delete. I repeated this ridiculous process till all maps, morph and uv were gone. - cant merge.
I saved and reloaded. - cant merge.

I realized I had merge on Auto (the points are at the exact same coordinates), and set it to Fixed and it finally seems to work. Which maybe means it would have worked earlier in this process.

Anyhow, the point is, or in this case multiple point in the exact same spot, this is weird.

MarcusM
08-21-2014, 01:10 AM
Maybe upload this model or only a part of it.

Sensei
08-21-2014, 11:11 AM
Thanks, but how do I delete all my maps?

f.e. use TrueArt's Delete Vertex Maps
https://www.youtube.com/watch?v=TS2lsN5WMpE