PDA

View Full Version : Noob question about animating an object



bellmore
08-16-2014, 08:56 PM
This is my very first attempt to animate something. I have always used Modeler and have never used Layout to animate anything (only single frame renders). I am trying to animate a block that moves back and forth on the Z axis with it bending in the middle like an elbow. But every time I set key frames, the block follows a path that I did not create that is not on the Z axis, I only set key frames while moving along the Z axis. I am such a noob with animating objects that I cannot even create a seemingly simple animation such as what I am trying to do. Here are some screen shots of what I want to do, 123679123680123681. The movements are along the Z axis but this is what I get instead,

ernpchan
08-16-2014, 11:05 PM
What you have is gimbal lock on your parent bone. I would suggest watching RebelHill's YouTube video's about coordinate space.

To manually fix this you'll have to go into the Graph Editor and fix your Heading and Bank values.

RebelHill
08-17-2014, 05:44 AM
Yeah... go through these fellas...

https://www.youtube.com/playlist?list=PLTds3QePYrWEWipwKkLmyNT4Tf_JTigM2

Also... set your default key type to linear in the graph editor, setting curve only on the animated channel... or just pick up the free edition of my RHiggit tools, and use the curve filters on the animation toolbox to perform quick fixes whilst working...

like here...

https://www.youtube.com/watch?v=00jA6ovM_8c

bellmore
08-17-2014, 09:42 AM
Thanks. I will go through the vids. Thank you for the help!!