PDA

View Full Version : HELP: Optimising Renders



Haven1000
11-25-2003, 08:49 AM
Hi there,

I'm a bit of a new-bee to Lightwave although I've used other 3D apps in the past.
I bought LW about 6 months ago but due to work commitments I haven't had much time to get to grips with all aspects of LW.
So at the moment I'm just working my way through tutorials etc.

I'm fairly comfortable with the modelling side now and have started my first test project. I've created a small scene (well to be exact it's the office I'm sitting in) added textures/ shaders etc., but I've sort of hit a brick wall when it comes to rendering. Most of the renders are taking a life-time compared with my previous rendering experiences on other 3D apps.

In short I was wondering if anybody out there would be willing to give me some tips on optimising the render times without compromising on the quality of the output. I'm mainly concerned with just producing stills at the moment at say 800x600.

My scene has about 150 thousand polygons (probably to much) with 1 light at the moment, I'm using LW 7.5C, OS 10.3.1, DPG5, 2.5G ram and a BTO 9800 pro card.

Any help would be appreciated

Thanks in advance.

Sean Martin
11-25-2003, 09:34 AM
With that spec you should be having no problems!

Try reducing the ray recursion amount in the render options panel, it's default is 16 which is to high for most scenes try setting it to 8 or 4 even.

mlinde
11-25-2003, 09:42 AM
Be careful about using radiosity or caustics, they will skyrocket your rendering times. In addition, don't render with anti-aliasing until you are in a final stage of tweaking the scene, render with Low or no AA. Then when you are done, make sure the final render has at least Enhanced Low AA or Enhanced Medium AA. Don't bother with high.

drclare
11-26-2003, 03:36 PM
Well, don't bother with high AA unless you have DOF and/or Motion blur in your scene, otherwise it will look terrible.

Beamtracer
11-26-2003, 07:03 PM
'Enhanced Low' anti-aliasing is usually enough for video. On rare occasions you may need to go to 'Enhanced Medium'. Anything higher is just overkill.

In the 'Rendering' panel, experiment with different 'thread' settings for multiprocessing. It can vary from scene to scene, but selecting '4-threads' is a good start for your machine.

Haven1000
11-27-2003, 02:40 AM
Thanks for all your advise.

I've tried some of your suggestions and I've been pleased with the results.

I've uploaded an image of the scene that I was originally talking about, it took 13h & 50mins, as I have a lack of experience in rendering with LW does this seem to be an acceptable time to take baring in mind my machine spec, the size of scene and render options:- Radiosity Monte Carlo/ all realistic render options on, Caustics on/ cached, Ray recursion limit 4, multithreading 4, AA enhanced low, 5 lights:- 4 area @ 30% and 1 distant.

Ge4-ce
11-27-2003, 05:07 AM
Personally I think that the 4 area-lights in combination with the radiosity make your scene skyrocket in rendertime!!

13 hours!! for this 800x600 image? Caustics etc on.. Ok..

But on a dual G5????????????

Could be ofcourse, but I think that with some tricks you should be able to get that rendertime down.. WAY down..

You can for example FAKE radiosity because that is your biggest renderhit..

Ok, I agree, the effect is not exactly the same, but think when you want to do an animation in this!! You'll be rendering a week for 1 second! undo-able!

Instead of using radiosity, put in some colored lights that shine at the ceiling for example. Use a beige light at 10% pointed at the ceiling to fake the lightreflection from the brown desk to the ceiling. (these lights have NO shadow)

Lower the specs on your arealights!

Turning of radiosity could possibly reduce rendertime by 10 times (especially with 4 arealights)

drclare
11-27-2003, 11:27 AM
Yeah, that seems like waaaay to long a rendertime for that image, even on my dual 800Mhz G4. I think you could definitely turn off radiosity, since i don't think it is really enhancing your scene that much. You can get the look that i think you're looking for with several low intensity spot lights even. And it probably doesn't matter in this scene, but since i don't really see the effect of caustics anywhere, i would turn that off. Caustics really only appear on really shiny or transparent curved surfaces.