PDA

View Full Version : Rendering strangeness on booleaned cylinders



digic
07-31-2014, 02:08 PM
I am trying to join 2 pipes at a right angle but after boolean subtracting the overlap it doesn't render proper (seams that shouldn't be there). Here's a couple of images of the object. Is there a better way to model this so that it will render properly?
123363123364

spherical
07-31-2014, 02:40 PM
Can you make that screen grab a bit larger? Can't really see what's going on with the inside surfaces.

Couple of questions:
Did you merge points?
Did they all merge or were there some that required welding?

digic
07-31-2014, 04:25 PM
Ok, here's a full-size screen grab. Yes, I merged points and no, I didn't weld any. It seems like there were a couple of points left that were not attached to any polys, that I just deleted.
123366

ernpchan
07-31-2014, 04:34 PM
An alternative to your boolean technique would have been to do it with subdivision surfaces. A QT on this page shows you how to do that.
http://www.pixelandpoly.com/video.html

JoePoe
07-31-2014, 04:57 PM
With the thickness of the tubes already present before Boolean it's not a simple matter of a subtraction.
You've got a lot of the extra junk polys left over from the boolean still in there (inside and outside the the final object). The wires from the side view should be a perfect "<" shape. 123368

It's going to be a pain to clean that up. At least I think so.

Apart from Ernest's suggestion of going SubD...... I would do two Booleans. One for the inside diameter and one for the outside. Unions this time. Apart from a merge.... no (okay maybe just a little ;)) cleanup. Make the end caps after (Bridge, or whatever).

spherical
07-31-2014, 05:12 PM
Thanks for the larger shot. Yes, there's a lot of geometry cruft in there. SubD is good or do the boolean on solid cylinders, delete the end circular polys and use Thicken.

JoePoe
07-31-2014, 05:52 PM
Of course Thicken(er, for me)! :foreheads. Only one Boolean, quite right. :)

digic
07-31-2014, 06:44 PM
Ok, I tried unioning the two solid pieces first and then subtracting the cores. The side seam looks better (although still somewhat visible) but now there's a new strange area along the top and front. Next I'll try using Thicken rather than subtracting the cores. If that doesn't do it, then I'll try the SubD method. Thanks for the link to the video. I had actually watched that a while back but forgot about where I saw it. Here's the latest version:
123372123373

spherical
07-31-2014, 10:02 PM
Those look like non-planars. Does Triple clear it?

bazsa73
08-01-2014, 01:35 AM
Thicken is such a great new tool. I love it.

jeric_synergy
08-01-2014, 12:57 PM
Thicken is such a great new tool. I love it.

"New"?? It's been around quite a while. :stumped:

digic
08-01-2014, 03:45 PM
I think they look like non-planars too but Modeler says I have 0 non-planars. I tried tripling them anyway but it still renders the same. So I started over and unioned the two solid cylinders and applied Thicken. Things went from bad to worse. It generated a bunch of non-planars in the interior, which I tripled. But the worst is the strange appearance of the (supposedly planar) quads on the unioned part (the other side still looks fine). Here's what I ended up with. I guess I'm going to have to go the SubD route.
123392123393

spherical
08-01-2014, 04:04 PM
Just tried a Union. Got the same display as the one in post #8. It's a function of Smoothing Angle. Increase it and they go away. You can minimize the Phong shading issue on surfaces like this, where there are internal angles (at the joints) that go counter to the external angles (between polys on the outer surface of each tube) by setting a surface for each. In this case, the vertical tube sides and the horizontal tube sides. Then, the smoothing does not try to happen at the joint between the two and you have more control over it. Also, don't obsess over the Modeler display of smoothing. Quite often, if you get the smoothing angle close, any artifacts that appear in Modeler don't in a render.

Then deleted end polys > Thicken. Got some extraneous points at the "V" on both sides of the vertical tube, 4 on the outside, 3 of them spread apart a little and 4 coincident on the inside. These created non-planars. Examined their relationship and welded. Non-planars gone. 4 of them are actually interior to the thickness, so can be deleted. No cruft on the interior.

When thickening, the points at the joint are moved at an angle, so they would have to be adjusted to bring them back into line with the rest of the tube points. So, if you really do need to have the interior of the tubes, SubD is better. If not, you can stop at the first paragraph, above.

digic
08-02-2014, 05:03 PM
I assume you're referring to the Smooth Threshold value in the surface editor. Thanks for the tip on that. I can greatly improve the appearance by playing with that but haven't been able to make it perfect. There always seems to be a seam showing up somewhere.

IIRC, I think I got some extraneous points after Thickening similar to yours.

I need the interior of the tubes because there's a place in the animation where they are semi-transparent (Object Dissolve) so I can show a valve inside the pipe.

I'll continue experimenting with it tomorrow.

spherical
08-02-2014, 08:15 PM
Phong shading is a mathematical trick that doesn't work for all circumstances. Sometimes just have to shoot for a happy medium between one area and another. Where this often gets me is high incident reflections on a flat surface, like a marble counter top, with smoothing turned on, the sides being the same material and a high poly count rounded edge that lowers the threshold angle of Smoothing. In a case like this, I set the top surface, as outlined above, to be a different surface with Smoothing turned off. Then, the sides and rounded edges are smoothed and the reflection on the top is undistorted.

Haven't learned whether you are actually seeing edges in the render or only in Modeler Smooth Shade.

EDIT: Found something while trying out moving the H & V tubes to separate layers. Thicken, in addition to creating extraneous internal polys at the angle joint, also created verticals that extend in both directions from the "V". Cutting the horizontal tube from the layer allowed seeing inside the volume of the vertical tube wall, exposing the extra polys. Had missed their normals showing up previously. Delete those polys, the Smooth Threshold can be nudged to just short of 90 and the edges disappear.

EDIT II: Just tried the Thicken plugin, as opposed to the native tool, and it does a better job. Still offsets the points at an angle along the joint, created fewer of the extraneous points at the "V" (bring the two back to where they should be and weld all four sets of four), created four internal polys along the angles at the "V" (delete them), did not create the two internal verticals. Turn on Smoothing and it is. On 36 side cylinders using this method, you turn down the Smoothing Threshold (went to 12.81) all on the one surface (no need to make separate surfaces to divorce them from each other) and it smooths right out.

Then tried to lower threshold setting on the previous model with the separated surfaces and they do the same; but at differing values. Essentially in an instance like this, setting the Smoothing Threshold to a value where it just smooths the surface is the key. No seams, no edges; inside or out.