PDA

View Full Version : A Few Annoyances....



MrFurious
07-31-2014, 01:21 AM
I wasn't sure weather to post this in Feature Requests, or maybe this functionality already exists and I haven't figured out how to...

* Persistent Scene/Dope Editor: I like having this window permanently open as part of my workflow. I can't imagine why one wouldn't, it contains so much useful info and is helpful to have open all the time. Problem.. every time I open a new scene or an existing scene I have to re-open the scene dope editor. The classic Scene Editor is persistent why cant the new one be also?

* Scene/Dope Editor List Ordering: another niggle I have with the Scene Dope editor is the list order.. again, non persistent. It always reverts back to 'name' order. I always use 'sequence' ordering. So every time I load a scene I have to a) open the scene /dope editor, then b) click around until sequence order is selected, Oh, and then Draaaaaaag the centre column until all my object names are clearly visible. Jeesh I've exhausted myself typing about it, and I find myself doing this countless times a day. All of the above should not require a single click and be there as I left it, like the classic scene editor. It's a real hassle for someone who uses Lightwave every day.

* Persistent Viewport Layout: Same deal.. I'm always reverting it back to how I want. The scene file seems to forget how I like my viewport layouts. Also in the preference panel under display --> viewport Layout --> "Set As Default".. this often forgets my default layout also.

* Image / Object Drop Down Menus: Can there or is there (or will there ever be?!) an option to list these in alphabetical order? With larger scenes and long image and object lists it can be a nightmare finding the specific image or object especially if I'm revisiting a scene I haven't worked on in a while.

jeric_synergy
07-31-2014, 01:46 AM
Some of those sound like your *.cfg files aren't being found, esp. the "set as default" bug.

Check your icons to make sure they aren't redirecting the *.cfg location.

MrFurious
08-02-2014, 02:53 AM
I'm not sure if it's a config issue. I've narrowed it down to this.. If I launch LW, and setup my viewports, object, cam and light default colours, shading modes etc. then quit lightwave and relaunch, everything is fine. IF LW crashes or hangs and I have to force quit, then.. my viewport defaults to a single pane, with cam and light default colours reverted back to defaults as well. Also any other panels I have open such as surface manager, image manager etc vanish and need to be reopened.

How do you mean 'check my icons'? If you mean the Layout and Modeler shortcut icons, I don't usually use them as I launch by opening a model or scene.

spherical
08-02-2014, 04:57 PM
If LightWave isn't closed in a normal manner, it has no opportunity to write its config files. Why it isn't reading the values written to the previous configs and opening that way is anyone's guess. I've never looked into how LW uses them as far as what happens when.

Yes, jeric was asking about the -c switch that is added to the commandline in a shortcut to read/write config files in a different location.

MrFurious
08-17-2014, 01:43 AM
It's very strange. Force quitting LW seems to be ok, but if LW crashes it has trouble reading my previous config. Have instigated a bug report though FogBugz but no response as yet..

p.s. I don't use a -c switch in the commandline/shortcut.