PDA

View Full Version : FiberFX polygonize bug



Boris Goreta
07-28-2014, 02:24 PM
If I use weight map to alter fur density when I use polygonize command to freeze the fur into 2 point polygons I get a lot of extra straight fur strands/guides perpendicular to each polygon. How do I fix this ?


123312

Boris Goreta
07-30-2014, 03:28 AM
Animals are suffering because of this, please help.

Greenlaw
07-30-2014, 09:13 AM
Hi,

I need to do some FiberFX R&D today. Will take a look at your scene while I'm at it.

G.

Greenlaw
07-30-2014, 09:16 AM
I haven't looked at the scene yet but, just to be sure we're on the same page, are you talking about the long bits in the object on the left?

G.

Boris Goreta
07-30-2014, 09:45 AM
Thanks, yes, those long bits are extra.

MSherak
07-31-2014, 11:42 AM
Thanks, yes, those long bits are extra.

So it looks like when you have the fiber type set to thin and polygonize it does the guides also. If you change it to thick camera and polygonize with 2 and billboard you should what you want without the guides generating. I would post this scene as a bug. Might be due to the weight map on the model. If you just add a sphere to Layout and thin polygonize it works fine.

-M

Edit : So saved your data. Created a new sphere with a weight map. loaded it in layout, applied FFX, loaded your settings in. Set the weightmap. Baked to thin and got the same results. So I think it is a bug related to the guides are weight mapped to store the vector values and polygonize for thin is reading those to bake since they have data.

Boris Goreta
07-31-2014, 12:29 PM
Thanks for finding this workaround. Actually the thick methods also produce guides but you can't see them because LW automatically sets visibility of the polygonized object to shaded, if you turn it to wireframe the guides are still there but now there is a method to delete just the guides. I need to set the thickness of the fibers to 1%, then generate thick fibers which will give me polygons, then all I have to do is go to Modeler and select the UV map and from the UV map window select the middle row of points , those are the guides, and delete them, then select the left or right point row and delete those so you get left with 2point polygons which I wanted from the beginning but wasn't able to select the guides and delete them. Thanks again !