PDA

View Full Version : How to render without the background colour ?



life3d
07-09-2014, 11:27 AM
Hello, im new to Lightwave, and i need to render only the assets i made without the background colour.
In windows - backdrop options there is no option to turn off the background or to make it transparent.

Can some one put me in the right direction?

Thank you in advance.

Mario

ernpchan
07-09-2014, 11:41 AM
Render to a format that includes the alpha channel, such as PNG32 or TGA32.

life3d
07-09-2014, 01:14 PM
Thank you for the help, i try PNG32 like you tell and works , but some meshes not render . I will do more render to see....

mario

ernpchan
07-09-2014, 01:27 PM
There could be multiple reasons why your mesh doesn't render. Does it have a surface transparency value of 100%? Is it checked off in the Scene Editor? Is it the checkbox 'Unseen By Camera' toggled 'on' in the Object Properties panel?

Greenlaw
07-09-2014, 04:03 PM
Normally you will want your Backdrop to be set to black (in the Image Processing window, Backdrop tab.) This will give you an image with a black background and an alpha channel. If you export a file with an Alpha, some programs will read this file as having a transparent background. In some programs, you may need to enable the Alpha channel to get transparency.

If objects are 'disappearing' in your render, something in the scene is probably occluding it or blocking the light. That or the render flag of the object is disabled, it's fully transparent or fully dissolved, or it's set to Unseen by Camera in the Object properties pane, or any number of other properties than can effectively 'hide' an object.

If you have a backdrop image or gradient, and you want to render that image as reflections or use it for lighting, but not render the backdrop itself in the background, here's what I like to do: Place a large inverted sphere in the scene that covers all objects, and in Object Properties, enable Matte Color, set to, and then set the Alpha Channel to Black. Then make sure Unseen by Rays, Unseen by Radiosity and Unseen by Fog are all enabled, and all Shadow properties are disabled. This will allow anything outside of the sphere to affect the objects inside, but it will prevent those outside items (i.e., gradient or backdrop images,) from appearing in the render directly.

To speed things up, I keep a scene with just the inverted sphere object (I just call it a matteSphere,) and I use Load Items from Scene to load the object with all the above render properties already preset.

G.

jeric_synergy
07-09-2014, 08:21 PM
I suspect the OP wants a rendered image that would give him/her the checkerboard transparency....thingy in Photoshop.

While this will happen in After Effects automatically, I don't think it will in Photoshop, although the alpha channel will exist. IIRC something else needs to be done to get to "transparent image" status.

Greenlaw
07-09-2014, 11:16 PM
Oh, yeah, you're probably right.

To the OP; In Photoshop that occurs if your image is saved from Layout as PNG 32. I don't think Photoshop will do that automatically with other formats--not even .psd. If you don't see a transparent bg in PS, there are several ways to make it transparent. For example, after unlocking the 'Background' layer in Photoshop (just double-click on the layer and click OK,) go the the Alpha channel and control click that layer. This will select the alpha channel. Then you can delete the black background in the RGB layer and make it transparent, or you can do this non-destructively by adding the alpha channel selection to a layer mask.

G.

jeric_synergy
07-09-2014, 11:57 PM
Good to know about the PNG32 import.

(I wish they'd quit cat fighting about a PNG animation format.... soooooooooooooo stupid. Just f**king DO it!)

bazsa73
07-10-2014, 01:44 AM
put there a black image on the composition panel and render with alpha

jeric_synergy
07-10-2014, 01:58 AM
No need to put a black image back there: just set the backdrop color to black.

life3d
07-10-2014, 04:31 AM
Thank you Guys,

I set the backdrop to black, save de render shot in png32/ tga32 and work. I was working with white backdrop and everytime a save the shot some parts of the mesh dissapear. Hope make sense.
Im new on Lightwave and sorry for some newbie questions .
I usually in other 3d soft, render my assets for games with no background color (turn background transparency to 0.0% ).

Lightwave as been till now a great experience, never is to late to join the rebellion....

Thank Mario