PDA

View Full Version : Relativity Expression and Jolt bugs --> workaround



Marander
06-24-2014, 11:29 AM
Hi

I've been trying to create camera shakes at specific events in an animation (ship passing by). It seems there are some issues with Jolt! and Relativity Dr. Camera Shaker. Reproducible in LW 11.6.2 32bit and 64bit.

Jolt!: Generally works fine but when working with negative frames (I needed to start the animation some 240 frames before), Jolt most of the time messes up the camera movement by adding random moves and rotations at various frames. Sometimes e.g. frame -240 until -110 works fine, starting from -111 there are huge random shakes (way beyond the configured Jolt parameters). Sometimes the whole animation is messed up. Sometimes after hours of trying and with much luck, Jolt works as expected even with negative frames. I also closed LW and deleted the dynamic cache without success.

Therefore I was looking into Relativity Dr. Camera Shaker. There I have found a completely different issue. I don't like shakes on the X and Z axis so I wanted only Y, H, P and B or even only rotation. When trying this it only moves and rotates on H (again spent several hours without success). I looked at the expressions more closely and found out the the generated expressions seems false: While rotating H results in e.g. #def+(IF(#n>0)*#r*0.080000), P and B results in e.g. #def+(IF(#n>0)*#p*0.080000). I guess the r is for rotation and p for position...?

However, when correcting the p to r for all the rotational expressions, it works as designed. See screenshots:
1) Dr. Camera Shaker settings
2) Wrong expressions
3) Corrected expressions
4) Correct rotation

Cheers, Marander

122518
122519
122520
122521