PDA

View Full Version : My new PC Lightwave doesn't read LW files created on my Mac



threedee12
06-17-2014, 04:28 AM
I need some urgent advice. I just bought a Windows PC having used Macs for the past 20 years, because I wanted to have a system with top power without paying 5K for a MacPro. The problem is I can't open any of my models or scenes I've created on my Mac Lightwave 11.6. I cant even import .obj files. Even files saved in LW 5 format won't import either. Is there a remedy?

threedee12
06-17-2014, 07:01 AM
I just sent my Mac Lightwave file (xxxx.lwo) to a friend with a PC and he could open it on his PC. He then re-saved it with a different name and sent it back to me. I was able to open this file on my PC without any problem. Is there something in Lightwave that needs to be configured. Does anybody have any ideas or theory what could be at the root of this?

threedee12
06-17-2014, 07:07 AM
It also doesn't read any surface textures brought over from my mac, including MaxwellRender Materials. There seems to be something wrong with file interface.

Red_Oddity
06-17-2014, 09:39 AM
My first reaction was either absolute paths in the files or a unix/windows line termination difference.
But since you can't open a .lwo either, it seems like something else is going on.

Not sure posting a file will help, but you never know.

Danner
06-17-2014, 10:22 AM
I'ts not normal behaviour. Backup and delete your configs, let LW recreate them. If that doesn't help try a LW reinstall.

Mr_Q
06-17-2014, 11:07 AM
Yes, there are zero issues sharing files between LW to Mac. I do it daily. I run two Macs, and two PCs. Something is wonky with your LW install. Start fresh.

cresshead
06-17-2014, 11:15 AM
indeed no hassles here either moving from mac to pc or pc to mac

threedee12
06-17-2014, 11:46 AM
I think I've found the culprit, Windows Lightwave doesn't like Mac Folders. After I deleted all the folders and replaced them with Windows folders with identical names I was able to open the files, but it took a while figuring this out. I always thought a folder was a folder and this doesn't seem normal. If you guys don't have these issues then there is something else wrong. It's a brand new PC and I installed everything from scratch.

raymondtrace
06-17-2014, 11:56 AM
Did the folders (and/or files) have blue (or green) names instead of black names when displayed in Windows Explorer?

threedee12
06-17-2014, 12:11 PM
Did the folders (and/or files) have blue (or green) names instead of black names when displayed in Windows Explorer?

No the names were all black.

- - - Updated - - -


I'ts not normal behaviour. Backup and delete your configs, let LW recreate them. If that doesn't help try a LW reinstall.

As I am a complete Newbee to Windows and PCs how do I delete my configs, where are they?

Danner
06-18-2014, 01:27 AM
from https://www.lightwave3d.com/support/faq/installation/

Deleting old config files can often solve many problems, and should be attempted as a first step.

Note: You should substitute 11 with the version number of LightWave you are using.
On 32bit machines the files will not have -64 in the filenames.

Config files location on Windows machines:
C:\Users\USERNAME\.NewTek\LightWave\11.0

Delete the files named:

LW11-64.CFG
LWM11-64.CFG
LWEXT11-64.CFG
Extension Cache-64
LWHUB11-64.CFG

Config files location on Macintosh machines:
USERNAME/Library/Application Support/NewTek/LightWave/11.0

Delete all the files, but not folders.

dyls_E
02-06-2017, 01:56 AM
Thanks, I was having the same issue, but once someone said about making new folders, i realised the mac folder had added a '' after the folder name. I thought it was a speck on my screen, but once i deleted that from the folder name, everything worked fine (with the exception of having to relink a few nodes)

Norka
02-06-2017, 06:17 AM
Do your Mac files have extensions on them?... .lwo .lws .obj .png .exr -- you need these in Windows.

Edit: You would need to enable showing file extensions in Windows' Folder Options to be able to see extensions (always a good idea) -- Make sure "Hide extensions for known file types" is unchecked. For some ridiculous reason, extensions are hidden by default in a new Windows installation.