PDA

View Full Version : Bump Map rendering issue



Nicolas Jordan
05-29-2014, 10:29 AM
I have been trying to move some of may production work back into Lightwave over the past while. I have been lighting most of my scenes with the light coming from roughly 90 degrees opposite the view angle so I see the side of the building in shadow. I use bump maps for stucco etc and get unwanted highlights in most scenes where you would not expect them since that bump map is totally in shadow. I have used Modo for a while and it's bump maps are rendered much differently than Lightwave. Is it just me? Am I missing something or is the bump map rendering in Lightwave in need of a overhaul? I know bump maps are a rendering illusion so they have to be faked to look convincing when rendered but there has to be a better way.

Has anyone else run into this issue?

Here is a link to this test scene in my dropbox https://dl.dropboxusercontent.com/u/3841099/BumpMap_Issue.7z

mummyman
05-29-2014, 10:41 AM
Only thing I can see, quickly, was that some of the bumps are set to 250 percent, so that overshoots their normal look...giving you what you have. Try 100 percent and work from there?

Nicolas Jordan
05-29-2014, 11:03 AM
Thanks for taking a look at it. I just cranked it up to 250% to make the problem more noticeable in this exmaple. Even if I change it to 100% the bump map problem still shows up in this scene. I can turn it down to 50% to make the problem disappear but then the bump map also disappears or is barely noticeable especially on the shadowed side of an abject with GI on.

mummyman
05-29-2014, 11:06 AM
I don't use normal maps, but maybe you can do something with those? Hopefully someone else can chime in that knows better... Good luck!

MarcusM
05-29-2014, 11:56 AM
Looks like in procedural texture settings the Scale should be max 1.0, Power 0.0-1.0 and bump value max 100%.

gerry_g
05-29-2014, 01:18 PM
122084think normal maps an expensive solution as they are made up of RGB values and hence three times as much as a bump map, maybe a gradient falloff on the bump or controlled gradient using light incidence or proximity to object and use a null

XswampyX
05-29-2014, 01:59 PM
Make your surfaces double sided.

http://i465.photobucket.com/albums/rr16/xXswampyXx/Bump_Probs_zpsf172fb2a.gif (http://s465.photobucket.com/user/xXswampyXx/media/Bump_Probs_zpsf172fb2a.gif.html)

Mr_Q
05-29-2014, 02:33 PM
Also experiment with the bump falloff feature or build a node flow that accomplishes it. Would also allow for more flexibility

djwaterman
05-29-2014, 05:07 PM
Looks like double sided is the solution. I didn't even know about this issue.

Nicolas Jordan
05-29-2014, 05:23 PM
Make your surfaces double sided.

http://i465.photobucket.com/albums/rr16/xXswampyXx/Bump_Probs_zpsf172fb2a.gif (http://s465.photobucket.com/user/xXswampyXx/media/Bump_Probs_zpsf172fb2a.gif.html)

Thanks! Making the surface double sided seems to fix this problem and render as I would have originally expected it to. I did notice that double siding can cause another problem with smooth shading curved surfaces at the edge of the shadow as seen here. You have to look a bit harder to see the shadows jagged edge on the sphere.



The double siding should work nicely for boxy architectural stuff.