PDA

View Full Version : Stubbornly shadowed: shadow switch non-working in raytrace + GI ?



jeric_synergy
05-23-2014, 12:48 PM
Working thru some slow-rendering tutes (why oh why do I turn on volumetric lights????), and even though I have a 'surround ball' in my scene w/all shadowing options OFF, it still seems to be rendered with shadows.

WUWT? I really just put it in there for a background texture (even though it will hose me on the alpha channel). I also have GI on, could that be part of the problem?


Tnx.

Chrusion
05-24-2014, 05:05 PM
Do you mean the sphere is SHADED to look spherical? Or are you saying it is receiving shadows from other objects and casting shadows on other objects despite all three check boxes in its properties panel being unchecked?

If the former, then this is due to DIFFUSE phong shading applied to all objects. The only way to "turn it off" is to set its surface to 100% luminous, 0% diffuse, and 0% specular.

If the latter, then I have no idea why LW is ignoring the shadow options in object properties.

lardbros
05-24-2014, 05:25 PM
GI could be the issue for sure.

Have you tried turning off radiosity on the object? Or turning off Occlusion in the radiosity options?

jeric_synergy
05-25-2014, 12:54 AM
Thanks guys: The surround ball contains everything, so it can't shadow itself, and I didn't want any shadows falling on it (although in the RW it definitely would: I wanted the effect that the ball is infinitely far away, but it's actually only maybe 2x as big as it needs to be). I just turned off the Olde School shadowing options, but there's the shadows, sharp and crisp as ray traced shadows are (so that lets out illumination from the instances, which aren't luminous anyway, and also aren't especially shiny).

Thanks lardbros, I'll look into those options! Many thanks.