View Full Version : Alembic export stripes out UVs

05-21-2014, 05:48 AM
I export my Alembic cache with UVs from Maya 2014,
import it in Chronosculpt, I do my sculpt and then
export the Alembic cache again.
I import this cache in Katana or Maya but unfortunately the UVs are gone,
they are not attached to the geometry anymore.
This result makes unusable my Alembic cache.
Any workaround or fix?


05-22-2014, 08:07 PM
What you want to do is just merge the cached animation back onto your original models, don't replace the models.

05-23-2014, 10:03 AM
Hi Jason
do you mean to do it with Maya cache? Because with Alembic you can't do what your are suggesting.


05-25-2014, 10:10 PM
In Maya did you try the Animation-Menu> Pipeline Cache> Alembic Import? In Alembic import there is a setting called "Import Under Current Selection" > Merge with two check-box options. I have successfully merged abc point cache onto meshes without having to replace them.

05-28-2014, 08:04 AM
Thanks Jason,
I gave a try but it didn't work.
Do you want I send you my Alembic cache this way you could try too?

Another weird thing is the export of the Alembic from Chronosculpt:

1) the Alembic file, with UVs, from Maya is 40 MB
2) the Alembic file from Chronosculpt is just 8MB, ok it is without UVs but the UVs info weights just few kilobytes not 32MB!!!
3) the Alembic cache exported from Chronosculpt has also a different subd level from the one exported from Maya...


05-28-2014, 06:50 PM
Yes, if you would provide a link I can look at any files you have. I'll report any bugs I find.

05-29-2014, 02:14 AM
Great, can I send you with wetransfer?

05-29-2014, 12:25 PM
not sure what that is but give it a go.

05-29-2014, 10:23 PM
I found a workaround that isn't too bad.

-) Instead of merging, use the alembic import to scene root option. You'll then have the sculpted mesh from Chrono without UV and the UV mesh that you already have inside of maya.

-) The two meshes should overlap each other exactly at this point. Select the UV mesh and then your target mesh without UV. Use the Polygons> Mesh> Transfer Attributes tool to transfer UVs to your imported abc mesh.

-) Select your imported mesh that has the newly transferred UVs and then go to Alembic Cache> Export Selection to Alembic. Make sure the UV checkbox is checkmarked in the options.

-) Now simply import your new abc mesh that has the UVs and cache together now (merge might not work) and apply your materials/textures to that object, cache should still be intact.

I'll report this issue to LW3DGroup

06-03-2014, 08:16 PM
Thanks for the help Jason!