View Full Version : Cant get 11.6.3 out of discovery mode

05-15-2014, 07:54 PM
Tried everything...ran as admin, manually copied the license file (it was already in the right location from the splash screen drag and drop install)
rebooted laptop, uninstalled LW, reinstalled....

all the license.key files are in the correct location, but no joy...
any tips?

win 7 64 laptop
11.6.3 64 bit

05-15-2014, 08:54 PM
When you say the .key file is "in the right location," you didn't forget to copy it into the C:\Users\<Your Name>\.NewTek\LightWave\11.6.3\licenses folder, did you? I always forget that the installation process always creates a new \<LightWave Version Number>\ folder...

05-15-2014, 09:35 PM
ya it's there....the splash screen drag and drop is putting the keys in the right place...I am sticking a copy in the bin folder as well....deleted configs everything

i had it working for a bit, then i scanned plug in folder and it went back into discovery mode

I am thinking this laptop needs a re-install of windows...other weird quirks happening as well

05-15-2014, 11:35 PM
Often there is something wrong with the windows firewall rules and how LW creates or uses them. Maybe that is an area where you can search for the problem? Most people opening threads about LW and license, finally had to reinstall LW to get it fixed.

121906 121907

05-16-2014, 09:06 AM
Well, I reinstalled windows (updated to 8.1) and I still can't get out of discovery mode....

Re downloaded my license key(just in case)....ran everything as admin...still no luck

Never had these problems before, not sure if it is a 11.6.3 issue, or something wrong with my key.

Waves of light
05-16-2014, 12:10 PM
I've seen similar issues with the licence key before. The following may help, but I can't guarantee anything:

Are you downloading your key from lightwave3d.com?
Are you running the installation .exe in administrator mode (Right click, run as administrator)
Find where you have installed the .exe for Modeler, Layout and the Hub. Right Click on each .exe and Go to Properties | Compatibility Tab | and set Privilege Level to 'Run as Administrator'
In your antivirus software, check to see if the modeler.exe, layout.exe and hub.exe have network access control set to 'allow' - I have norton and that's under Smart Firewall | Program Rules - I don't know what it will be for other AV software.

Hope this helps.

05-16-2014, 02:07 PM
Deuce just fixed it....

every drag and drop was adding to the license and the first line was corrupted....should have looked at it with a text editor

EDIT: spoke too soon, discovery mode came back...licenses are all fine
thats 2 times in 12 hours it has run then went back to discovery mode on the next startup...somethings quirky

Mr Rid
05-16-2014, 04:40 PM
I could not get my LW11.6 license to work until I removed brackets "[ ]" from the install folder name.

Some earlier version of LW defaulted to using brackets in the install folder name, and I stuck with that convention. But 11.6 was the first version that would not work with those characters.

05-16-2014, 05:15 PM
thanks for the tip...dont see any brackets in the folder name though

It will all run fine with my wireless network turned off...
as soon as i turn wireless back on my laptop its back to discovery mode.....

somewhat of a mystery

05-16-2014, 05:18 PM
Is any part of LW running anywhere else on the network?

05-16-2014, 06:10 PM
Yes my one machine is rendering away......hmmm I will try and see what happens if I shut one down.

05-16-2014, 06:15 PM
Is any part of LW running anywhere else on the network?


Where were you like 20 hours ago....I've just had newtek support scratching their heads over this, while I pulled my hair out

I was rendering on one machine and was installing LW on another...

05-16-2014, 09:07 PM
Well, I was here, reading the other responses as they came in, but that last tidbit of data you shared struck a bell, so I thought I'd toss it out there. Happy To Help.

05-17-2014, 03:47 AM
Today i have the same Problem. But no other PC is running with Lightwave. LW starts in discover Mode and i have no Time for try, must work with LW!

i have down the following:

- Network disabled/enabled
- Firewall disabled/enable
- C:\Users\user\.NewTek\LightWave\... complete deleted, older Version extract from Archive
- starts as Admin, noAdmin, casper...
- License file edited, unedited, new scripted, printed an crumpled...
- restart PC, restart Weekend, restart all

Lightwave remains in discovermode...

Now i have reinstall Lightwave - fixed.

05-17-2014, 11:34 AM
Well, I was here, reading the other responses as they came in, but that last tidbit of data you shared struck a bell, so I thought I'd toss it out there. Happy To Help.

Glad you did, thanks.

It's amazing how often I end up trying to brute force problem solve, when the answer is relatively simple and overlooked

08-29-2014, 05:08 PM
I am having this problem on my machine at home now. I haven't used LW there in awhile but had to take a project home with me and it won't launch. I've wiped out my license file and replaced it, reinstalled Lightwave (it was 11.6.2 but I downloaded 11.6.3 too to no avail), rebooted, etc. The only other computer on my home network is a Linux server which ain't running LW.

For fun I just pulled the dongle out of my normal work machine at the office and applied the software license file, and it doesn't work here either.

Does LW check in with some NewTek server when software licensing is used? Has my serial number gotten stuck as being in-use somewhere or has someone somehow stolen my license file?

08-30-2014, 01:03 PM
Re-download the license.key file?

09-07-2014, 04:25 PM
Yes.. reinstalled everything.. no go. I have to wonder if it's some Windows Update that broke something or what; having not changed anything about Lightwave for months, it just stopped working.

09-07-2014, 05:24 PM
Check your task manager for a 'zombie' instance of Layout running in the background. If you see one listed, kill it. Sometimes a crashed instance of Lightwave will get stuck in memory and may prevent the license from running properly for new instances. This happened to me and another artist at work a couple of weeks ago.

Also, if you're on a network, make sure Lightwave isn't running on another computer. This happened to me at home once--I spent a few hours trying to figure out why I couldn't get a license to take on my laptop, only to find that I had Lightwave running in the background on my workstation. After I shut down Lightwave on my workstation, it ran fine on my Laptop.

One more thing to check: be sure you're downloading and installing the proper license key. The old license file was called license.key; a new license file is called LICENSE.LWK.


09-07-2014, 07:39 PM
If you have a dongle, which is probable for commercial plugins to work, the existing LICENSE.KEY file format works; at least up to, and including, 11.6.2. Still checks across the network, but it runs.

I'd take a close look at your software firewall rules. Might be preventing communication.

09-07-2014, 09:45 PM
Yeah, I should have clarified what I wrote: You can't use the old license for dongle-free activation. As Spherical noted, the new key file should work for either dongle or dongle-free activation in recent releases of Lightwave.


09-09-2014, 12:58 AM
No zombie LW processes (I've rebooted several times while testing.) I am using the LICENSE.LWK as I was prior; I looked at Procmon and found all the places Layout is looking to make sure it's not finding and old license file somewhere else, and it's not. It reads the proper license but still fails to activate.

I'll just have to call tech support, hopefully in the next couple of days.

07-19-2015, 09:16 PM
OK I finally figured this out (for me anyway.)

Apparently LW requires the Windows Firewall service to be running in order to use the dongleless license. Since it appeared in Windows XP days, I've always stopped the Firewall service and disabled it since my machines are behind a locked down firewall already -- one less thing running in the background.

Started the Windows Firewall service, re-installed the last version of LW to let it add its rules to the firewall, and even though the firewalls settings themselves are set to 'Off', now LW works. Stop the service, break LW. Start it back up again, and it's fine.

07-19-2015, 09:31 PM
Booo! Very arcane. In the dox?

(Insert standard "user enhanced dox" argument...)

07-19-2015, 10:40 PM
Not that I've found. But now in my hindsight, a Google search ("lightwave windows firewall") revealed this:


Somewhat ironic, considering the source :)