PDA

View Full Version : volumetrics and particles help pleez



webshot
11-21-2003, 08:55 AM
Okay so I am not the particle king :) But ok I have a volumetric spotlight (light with vol applied) shining on my object. I am trying to accomplish the effect of sparks or sparkles releasing from the object. WHich I can do but. I would ike the particles to interrupt the light/volumetrics. This is what I am not able to do.

Could someone pleez lend me a clue on hw to do this. pleeez

Thanks in advance.

Axis3d
11-21-2003, 06:31 PM
Load in a simple box object into Layout. Hit 'm' to open the Motion Panel for it. Then add the FX_Link plugin. Also, click to turn on the Size Effect. Close this panel, then clone the box and type in the number of particles that are floating in your scene. Now you have the same number of boxes as particles. Also, the boxes have been automatically attached to each particle, but you can't see them yet.

Open the Emitter Panel, and under the Particle tab, scrub on the particle Size parameter (it defaults to zero, which is why you don't see the boxes at first). Give them a size which will be good for creating the shadows in your volumetric light. Next, you don't want the boxes to render, so you need to make all of them invisible. Open the Spreadsheet Editor. Select Object Properties: Render Flags. Then under the Unseen By Camera column, Shift + click the first and last box objects. Then, click on 'Checked' at the bottom left. Then click Apply. This will quickly make all of them invisible, yet still be able to cast shadows.

For the particle glow or sparkle thing itself, I would try using Hypervoxels. Click on Hypervoxels, then double-click on your Emitter object to activate it. You can load in an image from the Sprites directory in Lightwave and use that image and attach it to the particles in the Shading > Clips tab. You can adust the Particle size, etc.

Now, you can render. Hypervoxels will create the glints and the boxes (which are invisible) will create the shadows in your volumetric light. If your light is a spot, make sure the shadow type is set to Shadow Map.

webshot
11-21-2003, 07:52 PM
thanks I will try that....I think I am going to have some questions but I will wait till I actually try your suggestion all the way thru.

thanks